I have used the instructions given in the following link to fix the slow Hyper-V console of a Ubuntu Server box.

http://solyaris.wordpress.com/2010/05/01/ubuntu-10-04-on-intel-driver-and-server-frame-buffer/

I am hoping that there is a way to fix the problem before the install so that the installation routine won't take so long.

up vote 3 down vote accepted

Two possible suggestions you could try - during the install you should be given the option to edit your boot line.

Try adding video=vga16fb:off immediately before quiet splash.

Alternatively try the option vga16fb.modeset=0

  • awesome!!! the "vga16fb.modeset=0" option worked!!! – Corey Aug 16 '11 at 20:56
  • I now get the following error message on my new install "gva16fb: Unknown parameter 'modeset'" any suggestions? – Corey Aug 16 '11 at 21:08
  • once you've installed, you'll need to blacklist the vga16fb kernel module as per your linked article - you wont need to use vga16fb.modeset=0 in your grub boot option. – fossfreedom Aug 16 '11 at 21:46

From what I understood in your link, all your did was blacklist the vga16fb module so it won't load at startup. You can dynamically unload a module from the command line using the rmmod command. So if you are using the GUI installed try opening a terminal and running the command:

sudo rmmod vga16fb
  • can this be done from the server install disk, before starting install, so that the installer itself will not be sluggish? – Corey Aug 16 '11 at 16:07

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.