200

I have two VPNs setup on my Ubuntu machine, one using vpnc and one using PPTP. These were both setup using the GNOME network manager interface and work great. However on occasion I need to access this machine remotely - is there a way to connect or disconnect to these VPNs from the command line?

1
  • Does the vpnc command detailed here not work for you? Also, there are instructions for configuring and connecting to PPTP here. Do they not work? Commented Aug 16, 2011 at 18:23

2 Answers 2

312

If you want to interact with NetworkManager from the command line, you can use the "nmcli" command.

  • List all NM connections: nmcli con
  • Start connection (Wi-Fi, VPN, etc.): nmcli con up id ConnectionName
  • Down connection: nmcli con down id ConnectionName

More nmcli subcommands in the manpage).


Also note that regular users usually don't have permission to control networking. Using the commands above with sudo should work for most connections, but VPN specifically might fail with "Error: Connection activation failed: no valid VPN secrets."

If that happens to you, it's likely that the VPN password is stored in your user's gnome-keyring, which makes it inaccessible to the root user. This comment explains why.

To fix this, edit /etc/NetworkManager/system-connections/ConnectionName and under [vpn], change the password flags line to:

password-flags=0

If there is a line starting with Xauth password-flags, change it instead.

Then add the following below the [vpn] block:

[vpn-secrets]
password=YourPassword

If in the previous step you changed the line Xauth password-flags, add Xauth password=... instead.

Now restart network manager by:

sudo service network-manager restart

Then starting the VPN connection with sudo nmcli con up id ConnectionName should work without problems.

10
  • 2
    I wish there was a general disconnect command that would disconnect any VPN without having to specify its id. That would probably make this feature (I want) easier to implement. Commented Jul 6, 2014 at 23:15
  • If you're using ipsec (e.g. vpnc), you may also need to add "IPSec secret-flags=0" and "IPSec secret=<grouppw>" in their respective places
    – Matt
    Commented Nov 3, 2014 at 0:01
  • This still didn't fix me :( I get a message "Error: Connection activation failed: unknown reason."
    – dano
    Commented Mar 8, 2015 at 5:12
  • I take that back... after the 3rd time I ran the command it worked. 1st time is failed quickly. 2nd time failed slowly. Third time worked!
    – dano
    Commented Mar 8, 2015 at 5:14
  • 2
    Clear text PWs?? Really?? Does anyone have a SECURE solution?
    – user447607
    Commented Sep 2, 2016 at 15:24
5

ihashacks's answer with Matt's comments worked for me... almost. Had to tweak one line.

My password-flag line actually read: "Xauth password-flag". The accepted answer wouldn't work for me until I changed to the following

[vpn]
...
Xauth password-flag=0
IPSec secret-flags=0

[vpn-secrets]
Xauth password=<my pw> ## This is the one I changed.
IPSec secret=<group pw>

Not sure why my VPN connections have "Xauth" before every mention of password.

1
  • 3
    This is for some types of VPN, for example, the Cisco one; very helpful for these cases! There is a mistake, though: the correct case of one key is IPSec secret - otherwise, it's not recognized by NM.
    – Marcus
    Commented Sep 15, 2015 at 18:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .