2

I can no longer write to my SD card using the GUI (Files 3.10.1). If I use the command line I can successfully write to the SD card, but using the GUI gives me "Destination is read-only".

Using the command line I am the same user as the GUI. No elevated permissions such as sudo are being used. I am able to write using the command line with the same user that is not able to write using the GUI.

I was able to write using the GUI just fine yesterday. There was an update(s) this morning to Ubuntu, not sure if that has caused this issue.

I am running Ubuntu 14.04 LTS. To summarize, command line I can write, GUI I cannot.

edit: New test I just ran was to create a file using touch on the command line and deleting it via the GUI. I was successfully able to delete the file via the GUI. So I can delete, just not create/copy?

3
  • I'd like to know an answer to this. The only way I can copy files is via a terminal. I have no idea why the GUI complains but not a CLI command.... Commented Jun 24, 2016 at 19:50
  • 1
    The following link and links from it with more details may help you or at least explain what is the problem, askubuntu.com/questions/402236/…
    – sudodus
    Commented Jul 30, 2017 at 16:58
  • 2
    Possible duplicate of I Cann't Copy any file to My Pendrive
    – Melebius
    Commented Jun 12, 2019 at 8:07

2 Answers 2

0

This sounds very similar to this question; unfortunately I have not found an answer, but it may be worth checking out; I'd hate to have you go through the same diagnostic steps only to find out the same result.

2
  • Created a directory and changed the owner to myself all via the command line. Tried to copy a file into this new directory and still get the same error, "Destination is read-only". The drive itself works on Windows and has worked recently (yesterday) on Ubuntu. It's really confusing me why it no longer works. Commented Jan 13, 2015 at 14:38
  • I have looked high and low for an answer to this; I have ultimately had to use windows to check / fix mine, after that it works fine again in Ubuntu. Unfortunately, mine have all eventually gone back to 'read-only' in Ubuntu, regardless of the method I use to copy files onto them.
    – snurfle
    Commented Jan 13, 2015 at 14:46
0

I had a similar problem with a USB stick Ubuntu 16.04. I could read the files but not write (even though I was able to delete files on the USB stick).

The solution I found was rebooting ubuntu with the usb stick in. The write permissions now work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .