1

I've been trying to install Audacious on Ubuntu 14.04 but I can't seem to get it working.

I have already changed the mirror on Software Sources of Ubuntu Software Center to the main server but still doesn't install and still getting the errors.

Here are the commands and the errors:

sudo apt-get install audacious
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 audacious : Depends: gtk2-engines-pixbuf but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

So I tried installing gtk2-engines-pixbuf

sudo apt-get install gtk2-engines-pixbuf
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gtk2-engines-pixbuf : Depends: libgtk2.0-0 (= 2.24.23-0ubuntu1) but 2.24.23-0ubuntu1.1 is to be installed
E: Unable to correct problems, you have held broken packages.

I don't want to downgrade just to have Audacious. Hopefully someone had already fixed this.

UPDATE: I tried to install from a deb file as suggested. And here's what I got:

    Selecting previously unselected package audacious.
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 206985 files and directories currently installed.)
Preparing to unpack .../audacious_3.4.3-1_i386.deb ...
Unpacking audacious (3.4.3-1) ...
dpkg: dependency problems prevent configuration of audacious:
 audacious depends on gtk2-engines-pixbuf; however:
  Package gtk2-engines-pixbuf is not installed.

dpkg: error processing package audacious (--install):
 dependency problems - leaving unconfigured
Processing triggers for mime-support (3.54ubuntu1.1) ...
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for hicolor-icon-theme (0.13-1) ...
Processing triggers for man-db (2.6.7.1-1) ...
Errors were encountered while processing:
 audacious

After I installed the deb file of gtk2-engines-pixbuf by downloading this http://pkgs.org/ubuntu-14.04/ubuntu-updates-universe-i386/gtk2-engines-pixbuf_2.24.23-0ubuntu1.1_i386.deb.html. I then installed the deb file of Audacious. It finished installing but it didn't work. I tried to run 'audacious' on Terminal and here's what I got:

audacious
WARNING: Audacious seems to be already running but is not responding.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Transport/neon.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Transport/mms.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Transport/gio.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Input/sid.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Input/modplug.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Input/tonegen.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Input/cdaudio-ng.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Input/console.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Input/madplug.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Input/ffaudio.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Input/vorbis.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Input/psf2.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Input/aac.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Input/sndfile.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Input/wavpack.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Input/aac-raw.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Input/flacng.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Input/amidi-plug.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Input/xsf.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Input/vtx.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Input/adplug.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Input/metronom.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Output/pulse_audio.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Output/oss4.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Output/jackout.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Output/sdlout.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Output/alsa.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Output/filewriter.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Output/sndio.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Effect/compressor.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Effect/speed-pitch.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Effect/crossfade.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Effect/resample.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Effect/voice_removal.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Effect/bs2b.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Effect/echo.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Effect/crystalizer.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Effect/sox-resampler.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Effect/stereo.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Effect/mixer.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Effect/ladspa.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/General/gnomeshortcuts.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/General/song_change.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/General/mpris2.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/General/gtkui.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/General/search-tool.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/General/statusicon.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/General/notify.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/General/hotkey.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/General/skins.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/General/alarm.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/General/cd-menu-items.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/General/albumart.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/General/lyricwiki.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/General/delete-files.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/General/lirc.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/General/aosd.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/General/scrobbler.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Visualization/cairo-spectrum.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Visualization/blur_scope.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Visualization/gl-spectrum.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Container/asx3.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Container/cue.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Container/m3u.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Container/xspf.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Container/asx.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Container/pls.so is not compatible with this version of Audacious.
 *** ERROR: /usr/lib/i386-linux-gnu/audacious/Container/audpl.so is not compatible with this version of Audacious.
FATAL: No output plugin found.
  • After changing the mirrors, did you run apt-get up update? – xangua Jan 13 '15 at 15:44
  • @xangua yup I did run sudo apt-get update – JoenasE Jan 14 '15 at 4:38
0

Try installing Gdebi and then install from a deb file available on the net. One I found out >> http://pkgs.org/download/audacious

  • please see my update. thanks – JoenasE Jan 13 '15 at 12:16
0

I know this post is kinda late, but I wanted to share my answer since I also experienced this same issue in Ubuntu 14.04.2 LTS.

Fortunately I found this link: https://forum.ubuntu.org.cn/viewtopic.php?f=74&t=467364 where basically the solution was to enable the trusty-updates repositories, which will make it possible to install the older version of libgtk2.

I tried this and worked for me.

  • Although your answer is 100% correct, it might also become 100% useless if that link is moved, changed, merged into another one or the main site just disappears... :-( Therefore, please edit your answer, and copy the relevant steps from the link into your answer, thereby guaranteeing your answer for 100% of the lifetime of this site! ;-) You can always leave the link in at the bottom of your answer as a source for your material... – Fabby Jun 17 '15 at 18:25
0

I had the same problem, seems new version of audacious is installable. Download

http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu/pool/main/a/audacious/audacious_3.7-1~webupd8~trusty0_amd64.deb

And install it with gdebi

To stop the package complaining for depends:

edit /var/lib/dpkg/status,
find the package with the broken dependencies
edit the Depends: line.
-1

Go to Ubuntu Software Center and search for the package software-properties-gtk, install that package if it is not installed.

Open your dash by pressing the Super Key (Windows Key) and type software sources. Go into the application that appears and place a check mark on all the packages present there.

After doing it, execute the following commands one by one, in a terminal window ( Ctrl+Alt+T ) :

sudo apt-get remove --purge audacious (to remove the broken audacious package)
sudo apt-get dist-upgrade
sudo apt-get upgrade && sudo apt-get update
sudo apt-get autoremove
sudo apt-get autoclean

and then run,

sudo apt-get install audacious to install Audacious on your Ubuntu.

  • I can't find software-properties-gtk. Only software-properties-common – JoenasE Jan 13 '15 at 12:30
  • Answer updated :) – Sachin Kamath Jan 13 '15 at 12:34
  • 1
    I have a feeling that these two will just probably break my system: sudo apt-get dist-upgrade sudo apt-get upgrade && sudo apt-get update – JoenasE Jan 13 '15 at 12:41
  • It won't. Just don't interrupt it while it's running. Have some faith in Ubuntu :) Alternatively, you can skip dist-upgrade and check if it's working. – Sachin Kamath Jan 13 '15 at 12:42
  • 1
    No worries. I already got it working after I reinstall Audacious through Terminal – JoenasE Jan 13 '15 at 12:48

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.