1

On Ubuntu Studio 14.10, the CTRL+F4 seems to work as a shortcut for opening the 4th desktop (tested using a live DVD, without any customizations). However, I only need two desktops, so I reduced the number of desktops available and now CTRL+F4 is not doing anything.

In other distros, this shortcut is used to close the current tab in Firefox, and I would like to achieve that behavior on Ubuntu Studio too.

How can I do that?

  • try <Ctrl>+<w> for closing the current tab in Firefox. – sourav c. Jan 13 '15 at 11:20
  • Are you sure you didn't assign it(Ctrl+F4) to another behavior in keyboard shortcuts? – αғsнιη Jan 13 '15 at 11:37
  • @souravc: thanks for pointing that out, but I would prefer to use the same shortcut I use in other distros. – Helder Jan 13 '15 at 17:13
  • @KasiyA: I'm sure I didn't do that. However, I just tried it again using a live DVD, and updated the question with what I found. – Helder Jan 13 '15 at 17:14
0

Install Customizable shortcuts for Firefox. (Its an extension) https://addons.mozilla.org/en-US/firefox/addon/customizable-shortcuts/ enter image description here In preferences change the Tab closing shortcut. enter image description here enter image description here This might Do.

  • Unfortunately, after installing the addon, and going to Firefox Preferences > Shortcuts > Close Tab, I'm not able to set it to CTRL+F4, because when I press these keys, I get moved to the 4th desktop. – Helder Jan 13 '15 at 17:21
  • You have enabled desktop workspaces. Right? – Wolverine Jan 13 '15 at 19:10
  • It is enabled by default (and I would activate them if they were not, although with less than 4 workspaces). – Helder Jan 13 '15 at 20:55
0

Have you ever tried Ctrl+F4 in Firefox? Check out that first. There the shortcut have already been assigned for the same purpose which you have asked for. The shortcut key works in my firefox by default. For your information, the shortcut key works in Chrome too and you could use Ctrl+W to close the current tab in either browser.

  • Yes, I tried it (because it is what I use on other distros) but as I said "the shortcut CTRL+F4 is not doing anything". – Helder Jan 13 '15 at 16:52
  • Check out if it is reserved for any system purpose. – Wolverine Jan 13 '15 at 16:58
  • it seems so. I updated the question after trying again using a live DVD. – Helder Jan 13 '15 at 17:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.