4

I'm having trouble fixing my locale settings. A similar question has been posted earlier here:

How do I fix my locale issue?

But it proved unhelpful. My problem is not that the locale is not installed on my system, as most answers seem to suggest. Details:

$ locale-gen "nb_NO.UTF-8"
Generating locales...
  nb_NO.UTF-8... up-to-date
Generation complete.
$ update-locale LC_ALL="nb_NO.UTF-8"
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
    LANGUAGE = "en",
    LC_ALL = (unset),
    LC_PAPER = "en_NO.UTF-8",
    LC_ADDRESS = "en_NO.UTF-8",
    LC_MONETARY = "en_NO.UTF-8",
    LC_NUMERIC = "en_NO.UTF-8",
    LC_TELEPHONE = "en_NO.UTF-8",
    LC_IDENTIFICATION = "en_NO.UTF-8",
    LC_MEASUREMENT = "en_NO.UTF-8",
    LC_TIME = "en_NO.UTF-8",
    LC_NAME = "en_NO.UTF-8",
    LANG = "en_NO.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").

I am guessing my problem is related to either KDE or having a different OS language than my local language (I want everything to be in english, but have norwegian keyboard settings, currency etc).

I think this problem arose after changing some settings in the system settings dialog a while back, bug?

1
1

I managed to temporarily fix the issue by changing the system language from American English to British English.

I did it via the KDE System Settings > Locale > Languages dialog. Amusingly, it displayed an error message saying that replacing the current language was not permitted, but in practice it was since the new settings were applied when I hit the "apply" button, and restarted the machine.

Leaving question open until bug is fixed. Current local output:

$ locale
LANG=en_GB.UTF-8
LANGUAGE=en
LC_CTYPE="nb_NO.UTF-8"
LC_NUMERIC="nb_NO.UTF-8"
LC_TIME="nb_NO.UTF-8"
LC_COLLATE="nb_NO.UTF-8"
LC_MONETARY="nb_NO.UTF-8"
LC_MESSAGES="nb_NO.UTF-8"
LC_PAPER="nb_NO.UTF-8"
LC_NAME="nb_NO.UTF-8"
LC_ADDRESS="nb_NO.UTF-8"
LC_TELEPHONE="nb_NO.UTF-8"
LC_MEASUREMENT="nb_NO.UTF-8"
LC_IDENTIFICATION="nb_NO.UTF-8"
LC_ALL=nb_NO.UTF-8
3
  • I'm a little curious about how you fixed it. Can you please show us the output of the locale command after having made that change? (Can mention that I too filed a related bug report a while ago.) – Gunnar Hjalmarsson Jan 13 '15 at 13:43
  • Edited the answer. It does seem, however strange, that something "special" happens with en_US at the top there. In detail, in the GUI dialog I mentioned, I added british english to the right hand list, then removed american english from the right hand list, ignored the error msg, then apply and restart. – Yngvefaen Jan 13 '15 at 22:36
  • I would try sudo sed -i '/LC_ALL/d' /etc/default/locale (and reboot) to get rid of the LC_ALL entry. You should never set LC_ALL persistently on a desktop. – Gunnar Hjalmarsson Jan 14 '15 at 3:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.