0

I am trying to set up devkitPro for ARM use, but I continuously get an error while executing the last two commands. The commands are make and make install.

The tutorials I am following:

When I get to the make command, it gives me this error:

/opt/devkitPro/ctrulib/libctru$ sudo make
Makefile:6: *** ***"Please set DEVKITARM in your environment. export DEVKITARM=<path to>devkitARM".  Stop.

In the tutorials, it tells me to put that the following commands in my .bashrc, so I did, bit it will not work still.

export DEVKITPRO=/opt/devkitpro
export DEVKITARM=$DEVKITPRO/devkitARM
0

Try:

sudo DEVKITARM=$DEVKITPRO/devkitARM make

Though I must say that make doesn't usually require sudo. You probably need it because you're working off /opt, where files are usually owned by root, so it might be simpler to chown as neeeded and run just make:

sudo chown $USER /opt/devkitPro/ -R
14
  • I did those commands, and the first one gave me an error back. Am I supposed to do it in a special directory? The second did not give an error, but can you tell me what it did? bbnorman@bbnorman-Veriton-M460:/opt/devkitPro/ctrulib/libctru$ sudo DEVKITARM=$DEVKITPRO/devkitARM make Makefile:9: /opt/devkitpro/devkitARM/base_rules: No such file or directory make: *** No rule to make target `/opt/devkitpro/devkitARM/base_rules'. Stop. bbnorman@bbnorman-Veriton-M460:/opt/devkitPro/ctrulib/libctru$ sudo chown $USER /opt/devkitPro/ -R bbnorman@bbnorman-Veriton-M460:/opt/devkitPro/ctrulib/libctru$ – Brendon Jan 13 '15 at 0:21
  • @Brendon it changes the owner of those files to your user, so that you can modify files without needing sudo. As to the error, I think there might be some problem in your DEVKITARM path or in your installation of devkitARM. Either way, the variable works fine. – muru Jan 13 '15 at 0:23
  • Okay, should I give you my devkitARM folder location? Maybe you can help me put it in there. Also, should I be editing my .bashrc in home or bash.bashrc in etc? – Brendon Jan 13 '15 at 0:25
  • @Brendon You have already given the location, haven't you? (/opt/devkitPro/devkitARM?) As for setting variables, see: askubuntu.com/q/4667/158442 – muru Jan 13 '15 at 0:30
  • I will in the meantime. My devkitARM folder location: /opt/devkitPro/devkitARM. The location my environment points to: export DEVKITPRO=/opt/devkitPro export DEVKITARM=/opt/devkitPro/devkitARM – Brendon Jan 13 '15 at 0:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.