1

Fresh Ubuntu 14.04.1 install (kernel 3.13.0-44), fully updated (via wired connection) and with correct iwlwifi firmware driver (iwlwifi-7260-8).

Lenovo ThinkPad S440.

I can connect to the wireless network, here at work, from both Mac OS X, Windows 7 and from Ubuntu 14.04 on another ThinkPad (T500). I restarted the router to no avail.

I'm pretty clueless to what I should do to troubleshoot this issue and are grateful for any help.

About my system:

lspci|grep -i wi: 04:00.0 Network controller: Intel Corporation Wireless 7260 (rev 83)

sudo iwconfig:

eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11abgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=22 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:on       

nm-tool:

NetworkManager Tool

State: disconnected

- Device: wlan0 ----------------------------------------------------------------
  Type:              802.11 WiFi
  Driver:            iwlwifi
  State:             disconnected
  Default:           no
  HW Address:        F8:16:54:27:B5:A5

  Capabilities:

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points 
    FULLRATEAEBA:    Infra, C0:3F:0E:B0:AE:BA, Freq 2412 MHz, Rate 54 Mb/s, Strength 59 WPA WPA2
    Catalin_103:     Infra, C0:A0:BB:8D:18:19, Freq 2422 MHz, Rate 54 Mb/s, Strength 34 WPA WPA2


- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            r8169
  State:             unavailable
  Default:           no
  HW Address:        F8:A9:63:55:91:79

  Capabilities:
    Carrier Detect:  yes

  Wired Properties
    Carrier:         off


`rfkill list`:
0: tpacpi_bluetooth_sw: Bluetooth
    Soft blocked: no
    Hard blocked: no
1: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
2: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

dmesg|grep iwl:

[    6.465125] iwlwifi 0000:04:00.0: irq 63 for MSI/MSI-X
[    6.476126] iwlwifi 0000:04:00.0: loaded firmware version 22.24.8.0 op_mode iwlmvm
[    6.524174] iwlwifi 0000:04:00.0: Detected Intel(R) Dual Band Wireless AC 7260, REV=0x144
[    6.524437] iwlwifi 0000:04:00.0: L1 Enabled - LTR Enabled
[    6.524673] iwlwifi 0000:04:00.0: L1 Enabled - LTR Enabled
[    6.739827] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
[    6.940780] iwlwifi 0000:04:00.0: L1 Enabled - LTR Enabled
[    6.941012] iwlwifi 0000:04:00.0: L1 Enabled - LTR Enabled
[  223.540907] iwlwifi 0000:04:00.0: Time Event end notification failure

sudo lshw:

*-pci:2
             description: PCI bridge
             product: Lynx Point-LP PCI Express Root Port 3
             vendor: Intel Corporation
             physical id: 1c.2
             bus info: pci@0000:00:1c.2
             version: e4
             width: 32 bits
             clock: 33MHz
             capabilities: pci pciexpress msi pm normal_decode bus_master cap_list
             configuration: driver=pcieport
             resources: irq:18 memory:f0600000-f06fffff
           *-network
                description: Wireless interface
                product: Wireless 7260
                vendor: Intel Corporation
                physical id: 0
                bus info: pci@0000:04:00.0
                logical name: wlan0
                version: 83
                serial: f8:16:54:27:b5:a5
                width: 64 bits
                clock: 33MHz
                capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
                configuration: broadcast=yes driver=iwlwifi driverversion=3.13.0-44-generic firmware=22.24.8.0 latency=0 link=no multicast=yes wireless=IEEE 802.11abgn
                resources: irq:63 memory:f0600000-f0601fff

Update

I'm trying to connect to FULLRATEAEBA: Infra, C0:3F:0E:B0:AE:BA, Freq 2412 MHz, Rate 54 Mb/s, Strength 59 WPA WPA2 When I look in the message buffer I it looks like I'm connected and authenticated but then for unexplainable reasons, the kernel deauthenticate.

[ 2748.066675] wlan0: authenticate with c0:3f:0e:b0:ae:ba
[ 2748.068670] wlan0: send auth to c0:3f:0e:b0:ae:ba (try 1/3)
[ 2748.070496] wlan0: authenticated
[ 2748.073360] wlan0: associate with c0:3f:0e:b0:ae:ba (try 1/3)
[ 2748.077787] wlan0: RX AssocResp from c0:3f:0e:b0:ae:ba (capab=0x411 status=0 aid=5)
[ 2748.079346] wlan0: associated
[ 2793.931365] wlan0: deauthenticating from c0:3f:0e:b0:ae:ba by local choice (reason=3)

update 2

I found that I can connect at home without issues but I still can not connect at work. The weird thing is that I have an old T500 with ubuntu 14.04 that connects fine at work. Below is the dmesg messages.

dmesg for a connection fail (at work):

[ 5554.192997] wlan0: authenticate with c0:3f:0e:b0:ae:ba
[ 5554.195347] wlan0: send auth to c0:3f:0e:b0:ae:ba (try 1/3)
[ 5554.200817] wlan0: authenticated
[ 5554.201603] wlan0: associate with c0:3f:0e:b0:ae:ba (try 1/3)
[ 5554.205520] wlan0: RX AssocResp from c0:3f:0e:b0:ae:ba (capab=0x411 status=0 aid=8)
[ 5554.206777] wlan0: associated
[ 5600.638632] wlan0: deauthenticating from c0:3f:0e:b0:ae:ba by local choice (reason=3)
[ 5600.642070] cfg80211: Calling CRDA to update world regulatory domain
[ 5600.645259] cfg80211: World regulatory domain updated:
[ 5600.645262] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 5600.645264] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 5600.645266] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 5600.645268] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 5600.645269] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 5600.645270] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 5600.645279] cfg80211: Calling CRDA for country: DK
[ 5600.647737] cfg80211: Regulatory domain changed to country: DK
[ 5600.647741] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 5600.647743] cfg80211:   (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[ 5600.647744] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[ 5600.647745] cfg80211:   (5250000 KHz - 5330000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[ 5600.647747] cfg80211:   (5490000 KHz - 5710000 KHz @ 40000 KHz), (N/A, 2700 mBm)
[ 5600.647748] cfg80211:   (57240000 KHz - 65880000 KHz @ 2160000 KHz), (N/A, 4000 mBm)

dmesg for a connection success (at home):

[    6.532911] iwlwifi 0000:04:00.0: Detected Intel(R) Dual Band Wireless AC 7260, REV=0x144
[    6.532993] iwlwifi 0000:04:00.0: L1 Enabled - LTR Enabled
[    6.533233] iwlwifi 0000:04:00.0: L1 Enabled - LTR Enabled
[    6.664207] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[    6.664209] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[    6.664211] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[    6.664212] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[    6.664214] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[    6.664215] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[    6.711736] init: failsafe main process (660) killed by TERM signal
[    6.740856] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
[    6.761147] intel_rapl: domain uncore energy ctr 7461:7461 not working, skip
[    6.873429] r8169 0000:03:00.0 eth0: link down
[    6.873991] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[    6.874237] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[    6.875681] iwlwifi 0000:04:00.0: L1 Enabled - LTR Enabled
[    6.875917] iwlwifi 0000:04:00.0: L1 Enabled - LTR Enabled
[    6.884761] type=1400 audit(1421181675.200:11): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/lightdm/lightdm-guest-session" pid=956 comm="apparmor_parser"
[    6.891403] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[    6.891964] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[    7.553843] init: plymouth-upstart-bridge main process ended, respawning
[    7.559276] init: plymouth-upstart-bridge main process ended, respawning
[   10.489646] wlan0: authenticate with 52:67:f0:d5:cd:fc
[   10.491707] wlan0: send auth to 52:67:f0:d5:cd:fc (try 1/3)
[   10.498811] wlan0: authenticated
[   10.501626] wlan0: associate with 52:67:f0:d5:cd:fc (try 1/3)
[   10.511184] wlan0: RX AssocResp from 52:67:f0:d5:cd:fc (capab=0x411 status=0 aid=3)
[   10.511997] wlan0: associated
[   10.512017] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   10.512062] cfg80211: Calling CRDA for country: DK
[   10.513768] cfg80211: Regulatory domain changed to country: DK
[   10.513769] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[   10.513771] cfg80211:   (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[   10.513772] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[   10.513772] cfg80211:   (5250000 KHz - 5330000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[   10.513773] cfg80211:   (5490000 KHz - 5710000 KHz @ 40000 KHz), (N/A, 2700 mBm)
[   10.513774] cfg80211:   (57240000 KHz - 65880000 KHz @ 2160000 KHz), (N/A, 4000 mBm)
[   11.115993] IPv6: wlan0: IPv6 duplicate address fe80::fa16:54ff:fe27:b5a5 detected!

I did a system check with checkbox to test the wireless hardware and got a fail in wireless/wireless_connection. But the error message is a bit bewildering. Fontconfig warning: ignoring C.UTF-8: not a valid language tag

  • Before I propose any other solution, I suggest you start with the steps I recommended here: askubuntu.com/questions/496249/… – chili555 Jan 13 '15 at 0:16
  • I set the regulatory domain to DK and tried to connect - to no avail. I then used the network manager to ignore IPv6 - also to no avail. dmesg has the same info as I posted in the update. – dotnetCarpenter Jan 13 '15 at 1:45
0

I suggest you download and install the -9 firmware. Perhaps the driver will accept and load the -9 firmware in preference to the -8 that is now loading: 'loaded firmware version 22.24.8.0 op_mode iwlmvm.' Go here and download http://wireless.kernel.org/en/users/Drivers/iwlwifi?action=AttachFile&do=get&target=iwlwifi-7260-ucode-25.228.9.0.tgz Drag and drop it to your desktop. Right-click it and select 'Extract Here.' Now, in a terminal:

cd ~/Desktop/iwlwifi-7260-ucode-22.228.9.0
cp iwlwifi-7260-9.ucode  /lib/firmware

Reboot and check:

dmesg | grep iwl

We might also try a driver parameter:

sudo -i
echo "options iwlwifi 11n_disable=8"  >>  /etc/modprobe.d/iwlwifi.conf
exit

Reboot and tell us if the issue remains.

  • Thanks for using your time to help me @chili555. I already have iwlwifi-7260-9.ucode installed. ls | grep -i iwlwifi-7260: iwlwifi-7260-7.ucode, iwlwifi-7260-8.ucode, iwlwifi-7260-9.ucode I tried to disable -8.ucode as you said but after a reboot nothing has changed. – dotnetCarpenter Jan 13 '15 at 2:41
  • Hmm.. According to dmesg the 22.24.8.0 is still being loaded even after writing options iwlwifi 11n_disable=8 to the end of iwlwifi.conf – dotnetCarpenter Jan 13 '15 at 2:47
  • The 8s,in this case, are coincidental and unrelated. Is the connection improved at all? – chili555 Jan 13 '15 at 14:33
  • yes and no. I meant to update the question with my latest findings. It's a bit time consuming because I can't connect with my S440, here at work. But, I found that I can connect at home without issues. The weird thing is that I have an old T500 with the same ubuntu version that connects fine at work. I will update the question with the dmesgfrom my latest connection try and try to find the messages, from where I successfully connect at home. But it'll have to wait 'till I finish work today. – dotnetCarpenter Jan 13 '15 at 14:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.