1

I mapped the shutter --active command to alt-print screen for taking screenshots of my active window. Unfortunately, if Shutter is already open in another workspace instead of minimized, then Shutter will not take the screenshot until after it has started moving me to the workspace that the shutter window is open in. The only way to workaround this is to make sure shutter is minimized before trying to take the screenshot. This will result in shutter opening in your current workspace which is annoying for those of us who like to keep our workspaces organized.

Is there a way to have shutter take the screenshot without changing my view to the workspace shutter is currently open within? I have already tried disabling "auto hide main window..." and "present main window after taking a screenshot" inside behavior settings.

Youtube video of issue.

  • No matter what settings I choose, it doesn't show the behaviour you mention. Shutter either moves the shutter window to the current viewport or shows the snapshot on its own viewport, but the snapshot is always correct. Which Ubuntu version are you using? – Jacob Vlijm Jan 12 '15 at 12:07
  • Im usuing ubuntu 14.04 64bit. Shutter -v shows: 0.90.1 Rev.1259 – Programster Jan 12 '15 at 12:53
  • Added a video to help demonstrate. – Programster Jan 12 '15 at 13:00
  • Why are you using shutter not gnome-screenshot? Oh, and you can't put iframes in this site. – Tim Jan 12 '15 at 14:00
  • @Tim because shutter has a lot of features that I take advantage of. – Programster Jan 12 '15 at 14:31
1

If you really want or need to use Shutter, you can simply use the workaround below:

You can automatically have Shutter gracefully closed (not killed) before taking a screenshot, thus preventing the move to another viewport. Since it is gracefully closed, there is no risk of losing images; they are saved automatically.
After the screenshot, Shutter will be running so you will not notice the difference.

To make it work you have to map the command below to the key combination, instead of running shutter --active directly from the key combination:

kill -s TERM $( pgrep shutter );shutter --active
  • That works when one types it into the CLI, but I am unable to get it to work with setting keyboard shortcuts with gsettings through the CLI. E.g. programster.blogspot.co.uk/2014/05/… – Programster Jan 13 '15 at 10:40
  • @Programster I don't see why that wouldn't work, there is probably some kind of a clash. To test, you can add the shortcut via System Settings to an available key combination. If that works (I have it working here) there must be some kind of a clash. The script you mention should not be doing anything different than the manual way. – Jacob Vlijm Jan 13 '15 at 10:54
  • Silly mistake of mine, when executing the script, $( pgrep shutter ) was getting evaluated immediately so in settings it was looking something like so: kill -s TERM 10778; shutter --select – Programster Jan 13 '15 at 10:55
  • Perfect I am glad it works :) – Jacob Vlijm Jan 13 '15 at 10:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.