1

I am using Ubuntu 12.04 LTS. The synaptic package manager says that the latest hplip version is 3.12. But there are more updated versions. I bought a printer HP Deskjet Ink Advantage 1515 All-in-one and found that the minimum hplip version for this printer should be 3.13.8. (http://hplipopensource.com/hplip-web/supported_devices/combined.html).

  1. Why does the synaptic package manager shows that the latest version is 3.12?
  2. How can I update that hplip version from 3.12 to 3.13.8?

1 Answer 1

0
  1. Why does the synaptic package manager shows that the latest version is 3.12 ?

Because for 12.04 3.12.2-1ubuntu3.4 is the latest stable version on release. And nobody backported the package (there is no need for it due to the reason below).

  1. How can I update that hplip version from 3.12 to 3.13.8 ?

    • You can do it yourself. HP has an excellent track record and provides installers. And their installers are excellent so nobody feels the need to backport hplip.
    • Update your system to 14.04 (uses version 3.14.3) or 14.10 (3.14.6).
2
  • What is backportation ?
    – ddas
    Jan 12, 2015 at 10:18
  • "backport" is making software available for versions older than what it was intended for.
    – Rinzwind
    Jan 12, 2015 at 12:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.