I know this has been asked a few times but none of the answers worked for me.

I use the gnome terminal as default in Ubuntu 14.10 and I can't get unicode characters to show properly, mainly in vim airline.

I have set character encoding to unicode UTF8 in the terminal menu.

and LANG returns utf8:

echo $LANG

I have installed a patched font from https://github.com/powerline/fonts/

I have probably also tried other tips found on stackexchange that I now can't remember and I still see the weird characters:

weird characters

When I installed the same font on OSX with iterm it worked instantly.

I have also tried in other terminals on the same system like guake or using ctrl-alt-f1 and the result is the same. I have tried inside or outside tmux as well.

Any help is welcome.

  • Which specific font do you have? And what did you do to patch it? – Fabby Jan 14 '15 at 14:33
  • I have installed lots of those in the fonts repository. They are supposedly patched already. (The same fonts in iterm on mac work) The one I have chosen in the terminal is "Ubuntu Mono derivative Powerline Regular 11". I have tried various fonts and sizes. – Bastian Jan 14 '15 at 17:52

I've uploaded a Unicode test file which you should download and then cat in your terminal.

E.g.: cat ~/Downloads/Unicode-sample.txt and then use Shift+PgUp and Shift+PgDn in the terminal to verify whether all characters display correctly.

If you get the same results in your terminal as opening the original source file in your browser, your font is fine; otherwise, it's a dodgy font: use a different one. (I use "Envy Code R")

And once the terminal is fine, all applications running in the terminal will be fine as well!

  • thanks @Fabby, I can observe two things: first, the result is the same in the browser and in the terminal. Second, there is a significant amount of characters that are not recognized. If you take for instance "Kanbun", I cannot see any character, only the boxes with numbers inside as in the screenshot in the original question. Does it mean there is a system wide problem? – Bastian Jan 14 '15 at 19:40
  • Kanbun I don't have neither... Kannada: 2 chars missing. Miscellaneous Technical: a block of 7 chars missing. and then another 10-15 missing until the end... Same-same??? In the browser I've got everything except Kanbun and a few (<10) – Fabby Jan 14 '15 at 22:02
  • Kannada in my browser looks like that and in vim like that. Miscellaneous Technical in the browser and in vim – Bastian Jan 18 '15 at 9:05
  • what about "Envy Code R"? – Fabby Jan 18 '15 at 10:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.