I got an HP Split x2 with Windows 8 pre-installed. I deleted it, and installed Ubuntu. However, I was wanting to play a few games that didn't work too well on wine, so I created a NTFS partition and installed Win 7 (UEFI) in it.

Windows was overwriting Grub all the time, and after a tiring struggle, I decided to get rid of Windows 7. I deleted its partition, but UEFI would still try to boot into it, which produced a black error screen ("0xc0000225 - The boot selection failed because a required device is inaccessible").

I googled a bit, and was told that Windows 7 installs a bootloader in the first partition. Well, I booted from a live CD, and deleted that partition via GParted. Oh, boy. Apparently, that was the EFI Boot partition, and now my laptop won't boot into anything other than live/install USB drives.

I tried boot-repair, and it told me to create an EFI partition, which I have no idea how to.

Is this fixable? Do I have to format my entire hard drive? The Ubuntu partition is still there (according to GParted), it is just not accessible. Thanks!

3 Answers 3


Ok, this was tiring, but I fixed it. Here's how:

  1. Create a partition (FAT, first one in hdd, boot flag, 200MiB) via GParted on Ubuntu 14.04 live USB.
  2. Use ALT Linux Rescue / rEFInder live USB to boot into my Ubuntu installation (http://en.altlinux.org/Rescue).
  3. Follow the instructions at (an error occurred while mounting /boot/efi) to fix UUIDs.
  4. Run boot-repair (http://www.howtogeek.com/114884/how-to-repair-grub2-when-ubuntu-wont-boot/).
  5. Reboot the PC.

Thanks for trying to help me, hopefully this will help someone else in the future.


I have had same problem, and you try to enter tty, and enter this in terminal:

      sudo apt-get install --force-yes shim-efi-amd64   shim-efi shim-generic 

and then enter this in tty:


and then enter this in the tty:

     sudo apt-get update 
     sudo apt-get install - - reinstall ubuntu-desktop 

and then enter this in the tty:

     sudo dpkg - - reconfigure - a 

and it might work fine this way.

  • By "tty" you mean the Terminal? Because it produces an error: E: Unable to locate package shim-amd64-efi E: Unable to locate package shim-amd64 E: Unable to locate package shim-amd64-generic Keep in mind I'm on a live usb, and I've updated my repository in settings already. Sorry for my ignorance, lol.
    – H. Neto
    Jan 11, 2015 at 19:10
  • You are not online.
    – Michael
    Jan 11, 2015 at 23:32
  • Yes I am, I am posting from that machine right now (live usb). That is not the problem, I think.
    – H. Neto
    Jan 12, 2015 at 1:32

First of all, try to make some backups guys, if you don't know how to, search for it first. obviously i didn't, i already had made backups, months before this self-made disaster happened. But don't blame me if you mess things up.

Check here: https://help.ubuntu.com/community/BootPartition. It might work for you as it is, but I had to format that boot partition to FAT32 (instead of ext4) and label it to boot,esp in manage flags before using the recommended option in boot-repair, yep that's the one I used. Good Luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.