0

Ubuntu gives me an error on boot saying it can't find my Swap partition.

I ran free -m and this was the result. It says I don't have any swap memory. I can't post any images but these were the results.

MEM: total(3692) used(2357) free(1334) shared (248) buffers(84) cached(908)

-/+ buffers/cache: used(1364) free(2357)

Swap: used(0) free(0) shared(0)

I tried to see if a swap partition exists on my hard drive. It does. I have allotted 60 GB to Ubuntu.

1st sub-partition device: /dev/sda5

partition type: Linux

contents: Ext4 (version 1.0) — Mounted at Filesystem Root

2nd sub partition device: /dev/sda6

partition type: Linux Swap

contents: unknown

Can anyone help?

0

Please check out my answer here. There are steps to check which swap partitions are in use and instructions on making the OS use them.

  • Running "grep swap /etc/fstab" give me # swap was on /dev/sda6 during installation #UUID=60449995-e48e-4b1d-ad7b-25269c4aca95 none swap sw 0 0 /dev/mapper/cryptswap1 none swap sw 0 0 I added /dev/sda6 none swap sw 0 0 to /etc/fstab. On running swapon -a, I get swapon: /dev/mapper/cryptswap1: stat failed: No such file or directory swapon: /dev/sda6: open failed: Permission denied On running sudo swapon -a, I get swapon: /dev/mapper/cryptswap1: stat failed: No such file or directory swapon: /dev/sda6: read swap header failed: Invalid argument Can you help? – user85933 Jan 20 '15 at 13:24

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.