0

Original post

I'm using Ubuntu 14.04 LTS on a Toshiba Satellite S55-B5289--not sure what my wireless card is. The last time I had it on was a couple days ago, and I had no network problems. Today, I can't get reliable network access. Trying to ping www.google.com gets me anything from "unknown host" to 75% packet loss. I've been able to load the Google homepage once, but then I'll get dropped from the network.

I've got a Toshiba Satellite S855-S5378 with a RealTek RTL8723AE Wireless LAN 802.11n PCI-E NIC right beside it running Windows 8.1 with no network issues, and a couple mobile devices that aren't having network issues. The machine running Ubuntu is the only one having problems.

I've got some superficial Linux experience, but I'm definitely well in the "noob" category when it comes to networks and connectivity (Linux or otherwise). This kind of feels like a driver issue to me, but I'm clueless.

While writing this on my Windows laptop, my Ubuntu machine has been erratically connecting to and disconnecting from my home network. Where do I start in trying to fix this?

EDIT

It might also be useful to add that when I'm plugged in to the network, I have no issues. This is strictly a problem when I'm trying to connect to the network wirelessly.

EDIT 2

The requested wireless info output can be found here: http://paste.ubuntu.com/9707958/

FYI: The "shayler" network is the one I'm trying to work with. "freedompop" is my mobile hotspot. Any other networks are irrelevant.

EDIT 3

Okay, so after a lot of back and forth, and attempting a few suggestions, I'm starting to suspect my router. I've done some more extensive testing on my hotspot, and when that has a strong connection, the Ubuntu machine has no trouble staying connected and delivering great speed. I have a NETGEAR wnr2000v3 running the latest firmware (V1.1.2.6) and I'm going to see if I can find any known issues there. If anyone has any tips, thanks in advance.

Update

I'm still missing something. When I use my mobile hotspot, I have no connectivity issues at all. But even when connected to my home network I can ping just about any domain successfully from the command line. I get the same responses I get from the Windows machine.

I've found a couple posts that say "if you can ping a domain, but your browser still can't navigate to a website, try..." and I've tried those. I've turned off IPv6 and checked my DHCP settings. I haven't found any known issues.

Should I still be thinking driver issues, or are there other options?

Update 2015-01-21

I don't know why I didn't think to check this before, but when I use the laptop in the same room as the router, I have no issues. I would think, then, that this is potentially about router placement, but again, I've got 5 other devices within arm's reach of my Linux laptop that aren't having issues. and I wasn't having issues with the Linux laptop until recently.

Today I reset the router to factory settings, and then I tried my Ubuntu laptop again. I had an excellent connection for about a minute. I was able to load a couple of web pages, and then I tried to play a video from YouTube and everything ground to a halt. I shut down the browser and tried to get 50MB of updates using the Synaptic Package Manager, and the download never even started.

I've been walking around my basement office, and I'll intermittently get and then lose the signal--sometimes while staying in the same spot.

Is it as simple as having a shoddy wireless card? Or is it a cruddy driver? We've had the router for a while, and I'd be tempted to blame that if it weren't for all these other devices running smoothly.

1

If you have any problems regarding wireless network and you want to fix it,

Running "Wireless Script" is required.

Copy and paste the command below in your terminal.

 wget -N -t 5 -T 10 http://dl.dropbox.com/u/57264241/wireless_script && chmod +x wireless_script && ./wireless_script

and post the result on your post.

(Detailed usage is posted on http://ubuntuforums.org/showthread.php?t=370108 )\

Edit: It seems like your laptop have no problem in the Intel wifi driver(iwlwifi and iwlmvm). However, it does not work well. (deauthenticating from <MAC 'shayler' [AC2]> by local choice (reason=3) in the dmesg.

If I were you, I would test wireless router, like changing encryption options or something else. Also, googling messages in the dmesg would be helpful.

| improve this answer | |
  • Please see Edit 2 of my post – tmoore82 Jan 22 '15 at 2:50
0

Tip- dont forget you can always check your internet speed itself to see if your router is not putting out the speed at times you thing at times. I use https://www.speakeasy.net/speedtest/ just to further understand what kind of speeds im getting when having issues.

| improve this answer | |
0

I'm sure this was a diagnostic step that I skipped somewhere, but I found the problem this morning: wireless mouse. Yup. Somehow when I read through those posts that said "Turn off your cell phones, tables, microwave, etc." it never occurred to me to try turning off my wireless mouse and keyboard. And it turns out that the keyboard it not a problem. Just the mouse. When I turn off the wireless mouse, even if the usb dongle is still on and I keep using the keyboard, no problems. I'm sure this also explains why the wireless works when I go into other rooms. I wasn't carrying the mouse with me. As soon as I get out of range for the mouse to work, no interference, of course.

So extra dummy points for me, but I should note that this is device specific. I tried using the wireless mouse with another laptop, and no problems. So there might still be a driver discrepancy somewhere that could fix the problem. But for the moment I'm done investing time in it. I'm going to go get a mouse with a tail and move on to my next dumb mistake. :)

| improve this answer | |
-1

Most likely it is the default wireless driver. You might be able to install a proprietary, unsupported Linux driver for your wireless chipset. I know I have seen this issue with Broadcom wireless chips and Linux distros. No one will help you much once you do that. In the case of Broadcom chipsets there are some proprietary drivers that Ubuntu will let you pick. I am not sure about your adapter. The other option is to use a usb or pcie WiFi adapter that is compatible with the Ubuntu WiFi Linux driver or provides a kernel WiFi module.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.