So here is the situation, I was using Ubuntu 14.04 32 bits. Removed everything from the partition I had and created an additional Swap partition and installed Xubuntu 14.04 64 bits. When booting I can choose Ubuntu from Grub (I also have windows). Then black screen and few seconds later my laptop reboots. With some black rituals I eventually got my laptop to boot sometimes (hitting it, opening the cd drive at boot, some superstitious stuff). But sometimes it just won't boot and keeps rebooting.

Windows boots just fine

I removed one of the rams (I have 2x2Gb) and suddenly it worked. I tested with many boots and it was fine. I switched the rams and it still worked. So the problem seems to be with the 4Gb size of the RAM. My Swap partition is slightly smaller than the size of the ram, could that be a problem?

Otherwise what can I do exactly to start troubleshooting this problem. I have no idea where to start and what debug messages to read.

1 Answer 1


Hitting will not solve anything (since windows boot just fine), but it has to be done in order to teach who's the boss.

Having less Swap memory than the actual RAM wouldn't be a problem. I had a linux mint xfce installed in a bootable USB, no SWAP partition and still worked ok. I think it would be a hardware problem... You said you switched the rams (I understand both at the same time conected), but did you tried each ram individually in each slot in order to detect a problem with slots and ram?

Does Windows recognize 4gb RAM?

  • I meant I removed one RAM and worked with the other, then removed the other one and placed back the one I removed first, I tested with both slots, so in total 4 trials. Always worked.
    – Mehdi
    Jan 11, 2015 at 3:41
  • Can Windows see 4gb RAM? Jan 11, 2015 at 11:51
  • Yes it can, I upgraded from 32bit to 64 windows 7 few years ago in order to be able to get the extra fourth Gb.
    – Mehdi
    Jan 19, 2015 at 2:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .