I recently installed a "window manager" (Steam's Big Picture) that crashes on load, effectively preventing me from doing anything. I've thought of two possible solutions: one would be to edit the file that stores the default window manager, and change it back to LXDE; the other (maybe even easier) would be to re-enable password prompt before login, so that I can change the Window manager there. (But I don't know how to do either)


  • So, the problem sorted itself out, in a way: I cancelled everything Steam tried to do, and I guess the OS detected that the manager closed, and brought me to the login screen (where I was able to change it).
    – Khashir
    Jan 13, 2015 at 14:39

2 Answers 2

sudo gpasswd -d username nopasswdlogin

where user name is your log in name. That should make sure that you are not in the no password group.

  • 1
    Good point. You will have to boot into recovery mode to get a command line. Generally press shift after BIOS has loaded or almost loaded. See the Ubuntu wiki for detailed information. wiki.ubuntu.com/RecoveryMode
    – Rex
    Jan 10, 2015 at 17:19

Just in case it helps someone with this problem in newer Ubuntu versions (I just experienced it), there is no such group, but you can also disable autologin using GDM. Just edit /etc/gdm3/custom.conf file and comment AutomaticLoginEnable and AutomaticLogin.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.