0

I'm having the classic problem when trying to connect my laptop to wifi - repeated password dialogs, even though the credentials have been entered. I'm using the standard network manager.

Machine specs are -

  • Xubuntu 14.04LTS
  • Lenovo ThinkPad T430
  • Intel Centrino Wireless N 6205

Insecure networks can be connected to just fine...

I tested out debian xfce on this machine previously, and this page got my wifi working. I hesitantly tried it in xubuntu to no avail - after installing the iwlwifi drivers manually (as described here) as they are not in the ubuntu repos.

When running network manager from terminal, here is the output when I try and connect -

NetworkManager[2816]:  Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
NetworkManager[2816]:  Config: set interface ap_scan to 1
NetworkManager[2816]:  (wlan0): supplicant interface state: inactive -> scanning
NetworkManager[2816]:  (wlan0): supplicant interface state: scanning -> authenticating
NetworkManager[2816]:  (wlan0): supplicant interface state: authenticating -> associating
NetworkManager[2816]:  (wlan0): supplicant interface state: associating -> disconnected

It loops around between those last two indefinitely...

<pre>$ rfkill list all
0: tpacpi_bluetooth_sw: Bluetooth
    Soft blocked: no
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
5: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no</pre>
    $ lspci | grep Network
    00:19.0 Ethernet controller: Intel Corporation 82579LM Gigabit Network Connection (rev 04)
    03:00.0 Network controller: Intel Corporation Centrino Advanced-N 6205 [Taylor Peak] (rev 34)
$ dmesg | grep iwl
[    9.316455] iwlwifi 0000:03:00.0: can't disable ASPM; OS doesn't have ASPM control
[    9.317203] iwlwifi 0000:03:00.0: irq 44 for MSI/MSI-X
[    9.764860] iwlwifi 0000:03:00.0: loaded firmware version 18.168.6.1 op_mode iwldvm
[    9.778358] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUG disabled
[    9.778361] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUGFS enabled
[    9.778362] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEVICE_TRACING enabled
[    9.778364] iwlwifi 0000:03:00.0: Detected Intel(R) Centrino(R) Advanced-N 6205 AGN, REV=0xB0
[    9.778516] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[    9.800853] ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs'
[   40.579731] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[   40.586571] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
[   40.849802] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[   40.856653] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
[  982.322399] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[  982.329333] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
[ 1010.374609] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[ 1010.383406] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
[ 1736.676404] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[ 1736.683251] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
[ 1832.021397] Modules linked in: snd_seq_dummy bnep rfcomm uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core btusb bluetooth v4l2_common videodev media 6lowpan_iphc arc4 iwldvm mac80211 snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_codec_generic intel_rapl x86_pkg_temp_thermal intel_powerclamp coretemp kvm crct10dif_pclmul crc32_pclmul ghash_clmulni_intel aesni_intel snd_hda_intel aes_x86_64 snd_hda_controller lrw snd_hda_codec gf128mul snd_hwdep glue_helper ablk_helper cryptd snd_pcm thinkpad_acpi nvram snd_seq_midi snd_seq_midi_event snd_rawmidi snd_seq snd_seq_device snd_timer joydev serio_raw iwlwifi cfg80211 parport_pc mei_me ppdev snd lpc_ich mei wmi lp parport soundcore i915 drm_kms_helper video drm i2c_algo_bit mac_hid psmouse e1000e sdhci_pci ptp sdhci pps_core ahci libahci
[ 1835.176504] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[ 1835.183655] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
[ 2094.504128] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[ 2094.511431] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
$ uname -a
Linux t430 3.16.0-28-lowlatency #38-Ubuntu SMP PREEMPT Sat Dec 13 16:41:52 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Messing about with the router config isn't really a good option, as many devices use this network.

1

Fixed it... my fault!

I installed the wrong iwlwifi firmware, from Linux Wireless

These errors were caused by running the version for kernels "3.2+", when I'm on 3.16.

Installing the "2.6.35+" driver fixed it.

0

Try to set disable_hw_scan=1 in modprobe command

Open terminal and execute following command

  • sudo service network-manager stop
  • sudo modprobe -r iwlwifi
  • sudo modprobe iwlwifi disable_hw_scan=1
  • sudo service network-manager start
  • didn't work unfortunately... I also tried disabling wireless N using this method before, as I saw it referenced somewhere else. No luck. – oli Jan 10 '15 at 22:01

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.