1

I am completely new to Linux and Ubuntu and tried to install Ubuntu on my Asus C300 Chromebook following a guide. When I am in crosh having typed "shell" and then type

sudo sh ~/Downloads/crouton -t xfce 

I get the following message:

sh: Can't open /home/chronos/user/Downloads/crouton

What should I do in order to continue the installation and get it working on my chromebook?

5
  • 1
    Which guide did you follow, can you paste the link?
    – Filbuntu
    Jan 10, 2015 at 12:49
  • 1
    Could you please also explain What crosh is? @Filbuntu: edit approved. It now needs another approval from another reviewer.
    – Fabby
    Jan 10, 2015 at 12:51
  • "/home/chronos/user/" seems wrong to me? either user is chronos and "user" is obsolete or the 1st command is wrong.
    – Rinzwind
    Jan 10, 2015 at 13:10
  • @Rinzwind it is correct, that's just how chronos is structured
    – mchid
    Jan 10, 2015 at 13:29
  • If you want to run both Ubuntu and ChromeOS on the same computer, I can't help you but if you're only wanting Ubuntu, you can follow my answer here and it will replace Chrome(everything Chrome) with the full version of Ubuntu. Note: you can install a version of ChromeOS called Cloudready by NeverWare onto a USB (in the answer) and you'll be able to run Ubuntu natively and boot ChromeOS from a USB stick.
    – Amolith
    Jul 3, 2017 at 12:54

1 Answer 1

1

It seems you have not downloaded the correct package. What you have is a folder called crouton and what you need is a script-file named crouton.

You should change the name of the existing crouton folder or move it to a diferent directory before going further as you won't be able to have two items named crouton in the same ~/Downloads folder.

After you have renamed the crouton folder, download the crouton script file from here (make sure to download it to your ~/Downloads folder): https://goo.gl/fd3zc

source: https://github.com/dnschneid/crouton#usage

Then, run those commands:

sudo sh ~/Downloads/crouton -t xfce

and be patient and "answer the prompts like a good person" . . .

Now, you can go straight into xfce by using the following command:

sudo enter-chroot startxfce4

or, you can run it as a "special shortcut" with this instead:

sudo startxfce4

click here for more info

2
  • Thank You so Much! It all worked our very well after you helped me :) Hope you're having a great evening! or day depending on where you are in the world :) Jan 10, 2015 at 17:13
  • @LucasDhonyHenriksson no prob. if this works, please click the icon on the left to accept the answer, thanks!
    – mchid
    Jan 10, 2015 at 17:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.