2

First post here I think

I have a 14.10 box that used to be a 14.04 box. It's a media centre.

When it was a 14.04 box it booted up fine. Now though it doesn't. When it boots it pauses on "Waiting for Network configuration" for about 3 minutes. Then when it finally come up it doesn't start any network interfaces.

sudo service network-manager start    

will get things going again but I can't keep doing it for life. Please help me to figure out how to get it to start automatically again.

I'm on the verge of reinstalling but in the interests of overcoming problems rather than just trying to avoid them I thought I'd ask here.

Some google results keeps pointing me to a problem with /etc/network/interfaces but I've even gone so far as removing this file and I still have no luck.

Hoping you folks can help. This is pretty frustrating.

Happy to post contents of whatever would help.

  • Do you have a file named /etc/init/network-manager.override? – muru Jan 10 '15 at 8:14
  • have a look at this answer here askubuntu.com/a/249850/167115 you will have to change the ips to match yours accordingly but you should be able to get the right idea from here. I think by listing the ip gateway netmask etc here, it should start it up. – mchid Jan 10 '15 at 8:31
  • @muru nope, no such file exists. – kahlerisms Jan 19 '15 at 10:14
  • @mchid I think I've ruled out any problem with interfaces - problem seems to exist regardless of the contents of that file (or if the file even exists) – kahlerisms Jan 19 '15 at 10:16
  • So no other ideas guys? – kahlerisms Mar 15 '15 at 11:31
2

Your problem is that you have removed the file /etc/network/interfaces; you need this file.

The network configuration hangup at boot time is a common issue. To recreate the file, open a terminal and execute the following command:

sudo nano /etc/network/interfaces

Then, copy and paste the following into the file:

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).
#
# The loopback network interface
auto lo
iface lo inet loopback

Press CTRL + o and then press ENTER to save the file. Press CTRL + x to exit the file.

Restart network-manager:

sudo service network-manager restart

Finally, to make it start up automatically execute the following command:

sudo update-rc.d network-manager defaults

Reboot to check your work.

Please post any errors or fail.


If that doesn't work, edit /etc/init/failsafe.conf:

sudo nano /etc/init/failsafe.conf

Look for "sleep" and change the number from 20 to 5 so that it looks like this:

sleep 5

Then comment out the following lines by placing a # at the beginning of each line so they look like this:

# $PLYMOUTH message --text="Waiting for network configuration..." || :
# sleep 40

# $PLYMOUTH message --text="Waiting up to 60 more seconds for network configuration..." || :
# sleep 59

This changes the wait time from 2 minutes to 5 seconds.

One last thing you can do is reinstall network-manager to replace any missing files:

sudo apt-get install --reinstall network-manager
  • Got this response on the last command you suggested: The script you are attempting to invoke has been converted to an Upstart job, but lsb-header is not supported for Upstart jobs. insserv: warning: script 'mythtv-backend' missing LSB tags and overrides insserv: Default-Start undefined, assuming empty start runlevel(s) for script mythtv-backend' insserv: Default-Stop undefined, assuming empty stop runlevel(s) for script mythtv-backend' Same problem at next reboot - waiting for network configuration. Post boot I had lo but had to start network-manager manually for eth0. – kahlerisms Jan 10 '15 at 7:17
  • @kahlerisms well here's at least a fix for the waiting for network problem, this changes the wait to 5 seconds instead of having to wait 2 minutes. – mchid Jan 10 '15 at 8:24
  • Thanks for your help though unfortunately same problem after the network-manager reinstall. You're right I get to go and plug a keyboard in and start network-manager sooner, so that's a positive but it's still a poor workaround :( – kahlerisms Jan 17 '15 at 5:04
0

I recently re-installed my laptop (which has loopback, WIFI and wired network connections) from scratch and I found that it has "NetworkManager is not running" displayed when I click the NetworkManager applet, which is apparently not that strange. This was straight after an install which was disappointing :-(

My installation method for my laptop comes from an Ubuntu 14.04 Server base with some desktop components. The reason for this is that I have switched to OpenBox which is lovely compared to Unity and I don't run into the bugs I always do when customising XFCE... it's also lightning fast. Unfortunately sometimes because of this it's a bit difficult to google for answers...

If I installed the desktop version of Ubuntu I believe it will let you use the the WIFI when installing (which is very nice) however when you install the server edition there is no prompt for wifi and I ended up plugging in a cable for the installation, this left my /etc/network/interfaces looking like the following:

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet dhcp

Which is pretty reasonable and correct... however this configuration causes NetworkManager to not start, or at least be disabled... You need to remove all the lines which reference eth0 and then NetworkManager will start properly!

Pretty surprised at this, as I have three network devices. Surely I've just gone down from 2 network devices being managed by /etc/network/interfaces to one, so I don't understand why NetworkManager would refuse to start and manage my WIFI in both cases...

(Note: From blog post http://keyboardwritescode.blogspot.co.uk/2015/06/network-manager-hell.html )

0

This could be due to excess devices being in your /etc/network/interfaces configuration file, apparently Ubuntu / NetworkManager sees any non loopback device and decides that it does not need to start (properly). Details can be found at http://keyboardwritescode.blogspot.co.uk/2015/06/network-manager-hell.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.