0

I recently changed the /usr file permission to chmod 777, so I lost sudo. I used recovery mode to enable sudo back. However, sudo is working now but CD and pen drives are not detected.

I've tried the following codes: mount

/dev/sda1 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
gvfs-fuse-daemon on /home/bsvp/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=bsvp)

code: sudo mount /dev/cdrom /media/cdrom
output: no medium found on /dev/sr0

any help!.

I'm ready for a fresh install of ubuntu, but when i place the cd in drive and restart there is no fresh install windows.

0

once you have plugged your USB drive in, run

dmesg | tail

and it will show you the kernel output if it has detected it, and what label it has been assigned in /dev

then

mount /dev/*usblabel* /mnt

and

cd /mnt

should let you get to it.

  • tried all methods to mount cd/usb and failed. Finally i used a windows boot dvd and formatted the hard disk. After that i inserted the ubuntu live cd and magically it was loaded. why the heck it was not loaded when ubuntu was installed is what i dont know. – prasanna Jan 12 '15 at 8:00
0

If you just want to boot from a cd/dvd/usb, and it's a known good working bootable cd/dvd/usb, then it doesn't matter if you can't mount it anymore in your damaged Ubuntu.

You just want to boot from it. Probably have to change the first boot drive to your cd/dvd/usb in your computer's BIOS. Doing that varies by computer, probably press a key at boot time like DEL, or F1 through F12, could be a message saying what key it is at boot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.