On my Acer VN7-591G I just bought the wifi and Bluetooth (both on the same chip) are not currently working (using Ubuntu 14.10).

As stated by a sticker on the bottom of the notebook: "This device contains WLAN-Bluetooth module QCNFA344", but I can't find any information about this module anywhere on the net. The wifi module isn't shown with ifconfig, while the bluetooth seems to be recognized (bluetooth symbol is shown in upper right corner next to clock), but doesn't find any devices.

Any help would really be appreciated.


lspci output:

07:00.0 Network controller [0280]: Qualcomm Atheros Device [168c:003e] (rev 20)
    Subsystem: Foxconn International, Inc. Device [105b:e08e]

lsusb output:

Bus 002 Device 002: ID 8087:8000 Intel Corp. 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:8008 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 006: ID 04f2:b474 Chicony Electronics Co., Ltd 
Bus 003 Device 005: ID 06cb:2970 Synaptics, Inc. 
Bus 003 Device 004: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 003 Device 007: ID 0489:e092 Foxconn / Hon Hai 
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

output of hciconfig --all: (only the internal card)

hci1:   Type: BR/EDR  Bus: USB
    BD Address: 00:00:00:00:5A:AD  ACL MTU: 1024:8  SCO MTU: 50:8
    RX bytes:1229 acl:0 sco:0 events:51 errors:0
    TX bytes:1506 acl:0 sco:0 commands:51 errors:0
    Features: 0xff 0xfe 0x8f 0xfe 0xd8 0x3f 0x5b 0x87
    Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3 
    Link policy: RSWITCH HOLD SNIFF 
    Link mode: SLAVE ACCEPT 
    Name: 'ubuntu-0'
    Class: 0x6c0100
    Service Classes: Rendering, Capturing, Audio, Telephony
    Device Class: Computer, Uncategorized
    HCI Version: 4.0 (0x6)  Revision: 0x0
    LMP Version: 4.0 (0x6)  Subversion: 0x25a
    Manufacturer: Qualcomm (29)

the device is being shown as hci1, as i plugged in another bt-dongle via usb

  • Open a terminal window and post the results of the following lspci -nnk | grep -iA2 net lsusb
    – Jeremy31
    Jan 9, 2015 at 23:18
  • In addition please attach the results of hciconfig --all I suspect it is an Atheros AR3012 device that is not supported in the latest kernel but I might be able to help
    – Jeremy31
    Jan 9, 2015 at 23:54
  • Just one more sudo cat /sys/kernel/debug/usb/devices | grep -iA30 Port=07
    – Jeremy31
    Jan 10, 2015 at 14:11
  • sudo cat /sys/kernel.... (copy / paste) didn't output anything
    – rkn
    Jan 10, 2015 at 22:59

2 Answers 2


Download https://www.dropbox.com/sh/bx1gtf2oxwnv588/AADUBfza3w3e1YJKCufqeqZea?dl=0

cd Downloads
sudo modprobe -r ath3k
sudo modprobe -r btusb
sudo mv /lib/modules/$(uname -r)/kernel/drivers/bluetooth/ath3k.ko /lib/modules/$(uname -r)/kernel/drivers/bluetooth/ath3k.ko.bak
sudo mv /lib/modules/$(uname -r)/kernel/drivers/bluetooth/btusb.ko /lib/modules/$(uname -r)/kernel/drivers/bluetooth/btusb.ko.bak
sudo cp ath3k.ko /lib/modules/$(uname -r)/kernel/drivers/bluetooth/
sudo cp btusb.ko /lib/modules/$(uname -r)/kernel/drivers/bluetooth/
sudo modprobe btusb
sudo modprobe ath3k

You may get an error with sudo modprobe -r ath3k as I doubt it loaded but this should get bluetooth running

  • sadly after trying this, the builtin bluetooth module isn't even shown with hciconfig anymore - even after reboot
    – rkn
    Jan 10, 2015 at 22:58
  • Then you may have another issue going on dmesg | grep firmware please
    – Jeremy31
    Jan 10, 2015 at 23:17
  • yes, it seems so - using dmesg shows [ 1696.302321] usb 3-10: Direct firmware load failed with error -2
    – rkn
    Jan 10, 2015 at 23:25
  • Try this echo "blacklist ath3k" | sudo tee /etc/modprobe.d/ath3k.conf then reboot, open terminal enter sudo modprobe ath3k and see if bluetooth works
    – Jeremy31
    Jan 11, 2015 at 1:14
  • Still the same results as before (tried with both - original and your .ko files) - thank you very much for your help till now. Hope you didn't run out of ideas yet...
    – rkn
    Jan 11, 2015 at 8:42

There is currently no support for your device. I suggest you add to the existing bug report: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1383184

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.