2

Recently I apparently corrupted my /boot/efi partition, I got according error messages at boot and a manual console to remount it.

I tried to reformat it (mkfs.vfat 32), reinstalled grub (grub-install), and updated fstab to the new UUID, however now it still fails to mount with FAT-fs (sda1): IO charset iso8859-1 not found.

2

UPDATE: since /boot/efi became corrupted I slapped together a vulgar script to recreate /boot/efi. Use at your own risk!

After finding the message above (by entering the manual recovery commandline offered and running dmesg | tail) I tried manual mounting. This failed as well.

Googling turned up that one should check whether the module nls_iso8859-1.ko could be loaded. So I tried running sudo modprobe nls_iso8859-1. This turned up an error about nort beeing able to open the dependency database. Recreating the dependency database with depmod fixed the issue.

  • depmod fixed it for me, Thanks! – Chiptus Jan 14 at 7:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.