I have booted my ubuntu 11.04 on my other PC ( I have put my disk into it and booted it) and now don't know why, when I put it back to my lappy I get this error enter image description here

I cannot login to the GUI. I know I can repair it from the virtual terminal but how ? Can you help me on that ?

  • That seems package broken try dkpg-reconfigure gnome-desktop – Achu Aug 15 '11 at 10:46
  • I have tried this but it didn't work. I would like to reinstall the gnome-power-manager but I do not know how to do this. – Patryk Aug 15 '11 at 19:12
  • apt-get purge gnome-power-manager and apt-get install gnome-power-manager solved the issue – Patryk Aug 16 '11 at 18:25

So finally I have solved the issue with launching these commands in virtual terminal :

apt-get purge gnome-power-manager
apt-get install gnome-power-manager

This problem usually happens if the disk has errors (at least in my experience), and the solution is to check the disk from a Live CD or Live USB. To do that:

  • Run the Live CD in the system with the drive giving problems.
  • Open a terminal.
  • Run sudo fdisk -l to find your Ubuntu partition and it's location (for example, /dev/sda5
  • Run sudo e2fsck -f /dev/<nameofyourpartition>.
  • Allow for any permissions problems to be fixed.
  • Reboot to the installed system, and the problem should be fixed.

If this does not work, then you can reinstall the gnome-power-manager package in Synaptic (sorry if that is the wrong name; search first before reinstalling).


I have the same issue today. dpkg --configure -a didn't help at all or reinstall the power management package. In most cases, you just run out of disk space and you need to make room. check df -h


Problem: Filesystem Size Used Avail Use% Mounted on /dev/sda1 910G 910G 0 100% /

Solution rm /var/log/rinetd.log

I hope this help


I just had this same error, but it was down to my own stupid fault. I wanted to free some space on my Hard drive so I removed the /tmp folder using this command:

sudo rm -drf /tmp

I now know that I did not need to do that but, on reboot Ubuntu recreated the folder but the permissions were wrong, when I corrected them it booted.


Just fixed this problem on my this on Ubuntu 10.04. The problem was caused by doing a backup with rsync of my home directory and filling the partition to 100%. The solution was to:

(1) boot from a disk to get a command line terminal up - in my case using GParted partition editor on a DVD.

(2) create a temp directory that will be used to mount the full partition on. Use a command something like - sudo mkdir my_temp_dir.

(3) Use this temp directory to mount the full partition that exists on the pc hard disk. Use command something like - sudo mount /dev/sda3 /home/user/my_temp_dir. That second argument is the location (in my case) of the partition that's full. GParted shows a helpful graphic to see what exists and the statuses of the hard disk partitions.

(4) Change directories to the offending directory where the backups are stored. Use command something like cd /home/user/my_temp_dir/mybkups.

(5) Using command ls -l convince yourself you know which directory to remove. (5) Remove the offending directory and the files it contains using command something like sudo rm -r my_large_dir. Caution required with this command - anything it removes isn't coming back - so be sure.

(6) When that command has executed then exit out of command line terminal, close Gparted (or whatever you've used) and remove disk.

(7) Boot as normal and Login should be possible.


When your drive on which Ubuntu is running gets used up it generates:

Install Problem! The configuration defaults for GNOME Power Manager have not been installed correctly. Please contact your computer administrator.

Step 1: Ctrl + Alt + F1

Step 2: Log in: e.g user and your password

Step 3: check you directories to see which folder is using a lot of space e.g download

Step 4: rm -f -r /home/user/download

With the above steps you will delete some folders or files and create space


I have got the same error and could not login to my linux for several hours.

When you prompted user list to login. Press ctrl+Alt+F2 You will be entered into a terminal. Login with your username & password. Delete all files under /var/log. This has fixed my problem.


I could solve the same issue by cleaning /media/* path. below cmd may help some one.

cd /media
sudo chmod 777 *
sudo rm-rf *

The actual issue in my case was, mounted volumes put a trace in /media path which crashes the login with message "The configuration defaults for GNOME Power Manager have not been installed correctly".

  • 2
    Do you understand that this can wipe away all data from your mounted volumes? Thank god for that typo. – Mahesh Aug 11 '12 at 9:02
  • Unmounting the volume with sudo umount /media/VolumeName seems like a much more appropriate approach... – Eliah Kagan Aug 25 '12 at 21:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.