I'm having trouble because I want to connect to my EC2 server through my new installation of Ubuntu 14.04 and I just can't.

I already downloaded the .pem key and added my server to the ~/.ssh/config file like so:

Host myhost 
HostName myhostdns
User ubuntu
IdentityFile ~/.ssh/mykey.pem
Compression yes

I also found that the window changed from this:


To this:


I now I could use another client but I'm configuring this machine as simple as I can.

2 Answers 2


Finally solved it!

I don't know why but Nautilus 3.10 treats in an odd way the ~/.ssh/config file, or at least this is what I've experienced.

This is how my ~/.ssh/config file looks like:

Host aws_host
  HostName [host ip addres]
  User ubuntu
  IdentityFile ~/.ssh/your_key.pem

DO NOT use your DNS name on your "Host" OR "HostName" variables or you may get an error saying Unable to find the requested location. Please check the spelling or the network settings. or an error saying Don't have permission to access the requested location.

The next step is to go to File -> Connect to Server... and in the Server Address bar write: sftp://ubuntu@aws_host and you should get your sftp drive mounted.

enter image description here

I'm really surprised of how difficult it was to find this simple answer on the internet, everybody just goes around and sugests that you use Filezilla.


Try using the IP or URL of the server, preceded by ssh like this:

ssh://(ip address) or ssh://URL

See the example:

enter image description here

As you see, you can use other prefix like smb (samba) sftp (FTP over SSH), dav for webdav or davs for webdav over SSL.

  • I've tried it but I get a message saying "Don't have permission to access the requested location". Jan 8, 2015 at 23:49
  • The same happens if I use sftp:// instead of ssh:// Jan 8, 2015 at 23:51
  • The only other thing I can think of is if you reinstalled your client, maybe the keys are no longer recognized by the server. Can you connect trough terminal with ssh normally? Also, as a recommendation I switched from nautilus to nemo, which in the latest version has a much better interface than nautilus. Jan 9, 2015 at 17:02
  • I can connect through the terminal with the command: ssh -i .ssh/mykey.pem [email protected] I can also connect through gnome3 (Debian) and even on a Mac using Cyberduck Jan 9, 2015 at 18:32
  • Also with Filezilla in the same machine Jan 9, 2015 at 19:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .