Sometimes the wireless connection is disconnected and turned off the computer must do to correct it.

A full update was done to try and fix this, and I searched many forums for this problem but i found nothing.

Here is my wireless information:

[0280]: Intel Corporation Centrino Advanced-N 6200 [8086:422c] (rev 35)

  • Please add some hardware information to your question, see here: askubuntu.com/questions/14008/… – Jorge Castro Aug 16 '11 at 22:03
  • 00:16.0 Communication controller [0780]: Intel Corporation 5 Series/3400 Series Chipset HECI Controller [8086:3b64] (rev 06) <br /> 00:19.0 Ethernet controller [0200]: Intel Corporation 82577LM Gigabit Network Connection [8086:10ea] (rev 05) <br /> 03:00.0 Network controller [0280]: Intel Corporation Centrino Advanced-N 6200 [8086:422c] (rev 35) – Netmoon Aug 17 '11 at 19:12
  • I don't think that's the wireless card, can you edit your question and just add the entire stanza? I can edit it to be correct after I identify which card it is. – Jorge Castro Aug 17 '11 at 19:20
  • sorry i don't know what do want, i'm begginer in ubuntu. when i use "lspci" i see the big list of hardwares. can you say exactly which part of this list ? – Netmoon Aug 17 '11 at 19:30
  • today connection not stopped, and i don't know why. but it's good for me. but i am waiting to see wether this will be fixed ?! – Netmoon Aug 17 '11 at 19:33

There is a very good step by step wifi support section on the Ubuntu site at


Work carefully through this site following the instructions in order. This can fix many problems. You might want to do this with a wired connection available in case things go wrong.

Once you have done this very carefully see if the problem is solved.

If you problem has not been solved after working through this you can do the following that might help (it does for me on my netbook). Connect to the wired connection. Go to the software section and install WICD. Go to system settings-startup applications and add WICD as a start up. Uninstall network manager (this is very important). Reboot and see if this helps.

  • thanks alex, But your guide is for people that their connection is completely severed. – Netmoon Aug 17 '11 at 19:36

I have a Latitude e6510 (same wireless hardware) running Ubuntu 11.04 and my wireless works flawlessly.

I know this series of laptops has a hardware switch along the right side to kill any wireless connections. Are you sure you aren't accidentally flipping that switch? The next time this happens try toggling the switch, does that fix the connection?

  • no, i should restart my computer to solve this problem ! but this is not conclusive and if this problem not fixed,finally wireless router should be restart to fix. – Netmoon Aug 17 '11 at 19:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.