Hi so I've been going at this for hours and I have installed everything correctly, I'm using a HP 14 chromebook, and I hear you can get minecraft on it, with downloading a Linux desktop.

I'm using Ubuntu 14.04 and unity, whenever I start my minecraft with OpenJava or oracle I get this error startup:

Java HotSpot(TM) Client VM warning: Using incremental CMS is deprecated and will likely be removed in a future release
Java HotSpot(TM) Client VM warning: You have loaded library /home/brodie/.minecraft/versions/1.8.1/1.8.1-natives-7251460222853/liblwjgl64.so which might have disabled stack guard. The VM will try to fix the stack guard now.
It's highly recommended that you fix the library with 'execstack -c <libfile>', or link it with '-z noexecstack'.
Exception in thread "main" java.lang.UnsatisfiedLinkError: /home/brodie/.minecraft/versions/1.8.1/1.8.1-natives-7251460222853/liblwjgl.so: /home/brodie/.minecraft/versions/1.8.1/1.8.1-natives-7251460222853/liblwjgl.so: cannot open shared object file: No such file or directory (Possible cause: can't load IA 32-bit .so on a ARM-bit platform)
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1929)
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1847)
at java.lang.Runtime.loadLibrary0(Runtime.java:870)
at java.lang.System.loadLibrary(System.java:1119)
at org.lwjgl.Sys$1.run(Sys.java:73)
at java.security.AccessController.doPrivileged(Native Method)
at org.lwjgl.Sys.doLoadLibrary(Sys.java:66)
at org.lwjgl.Sys.loadLibrary(Sys.java:95)
at org.lwjgl.Sys.<clinit>(Sys.java:112)
at bss.I(SourceFile:2488)
at net.minecraft.client.main.Main.main(SourceFile:41)
  • Still need help – Trek Craft Jan 8 '15 at 21:02
  • Can you post the version of Java that you are using<br> java -version<br> And are you trying to run the Minecraft client or the server? – user367031 Jan 9 '15 at 1:58

Possible cause: can't load IA 32-bit .so on a ARM-bit platform

Running Minecraft on an ARM processor is not supported, except for the RaspberryPi version of Minecraft for Raspbian. But if you want to give it a try, install liblwjgl-java, liblwjgl-java-doc and liblwjgl-jni by and liblwjgl-java-jni

sudo apt-get install liblwjgl-java liblwjgl-java-doc liblwjgl-jni

sudo apt-get install liblwjgl-java liblwjgl-java-jni

Replace the with Minecraft prepackaged x86/x64 lwjgl files with the ARM files:

~/.minecraft/bin

  • jinput.jar replace with the file from /usr/share/java/
  • lwjgl.jar replace with the file from /usr/share/java/
  • lwjgl_util.jar replace with the file from /usr/share/java/

~/.minecraft/bin/native/.

  • libjinput-linux.so replace with the file from /usr/share/java/
  • liblwjgl.so replace with the file from /usr/lib/jni

useful command (cp stands for copy):

cp /usr/share/java/[filename] ~/.minecraft/bin/

adjust it to meet your needs.

Afterwards it should work, but don't expect it to be running fluently, the computer will not be powerful enough.

source of the biggest part of the answer: Minecraft on a Samsung ARM Chromebook

  • Hi, i tried that in the Xterm. and it could not find the last 2 liblwjgl's and then i tried since the frist one did. same results :/ please help – Trek Craft Jan 8 '15 at 19:27
  • You are totally right, I made a mistake, the post is now upgraded. – Gert Jan 8 '15 at 22:17

Why bother with a problem, if there is a simple alternative:

'Unofficial Minecraft Installer' is a script available in a PPA that can be used to easily install the popular Minecraft game in Ubuntu and derivatives (Linux Mint, elementary OS and so on).

Source

sudo add-apt-repository ppa:minecraft-installer-peeps/minecraft-installer
sudo apt-get update
sudo apt-get install minecraft-installer

Once installed, run Minecraft from the menu / Dash, login with your Minecraft account and the installation should start automatically.

Source

  • @TrekCraft Were you satisfied with my answer? Then give me a upvote (∧). If I could solve your problem, then it would be nice if you'd mark my answer (✓). ;) – A.B. Apr 18 '15 at 14:55
  • 1
    Simplest is always best. +1 – Fabby Aug 14 '15 at 19:52

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.