1

Hi I upgraded my Ubuntu GNOME 14.10 fresh install to Gnome 3.14 by using the gnome team ppas. I'm using a Sony E11 64-bit AMD laptop. After rebooting I was greeted with a blank screen, and I can only login to the terminal. Running startx as a normal user or with sudo privilege , doesn't help, only when I'm logged in as root (after sudo -i)

When I login to the terminal I'm greeted with the following text:

systemd-logind[1071]: Failed to start unit user@1000.service: Unknown unit: user@1000.service

How can I fix this?

5

I had this problem too and I fixed it~

It's because the gdm package is broken.

login to terminal and temporarily change your greeting screen back to lightdm(you can change back to gdm later) by typing this:

sudo dpkg-reconfigure lightdm

and select lightdm thensudo shutdown -r now to reboot

and you can login normally. If you still want to use gdm as boot screen, reinstall it by sudo apt-get install --reinstall gdm and do a sudo dpkg-reconfigure lightdm again.

Please accept my answer if you found it helps, thx ~

  • Didn't work... I had to install lightdm though. But it won't let me login. The password entry box is not visible, though it accepts passwords. Once you try to login though, it throws you back out to the login screen. GDM is still blank. – SinaOwolabi Jan 8 '15 at 17:53
  • It kind of works, at least now I can login. GDM still borks, though. Thank you! – SinaOwolabi Jan 9 '15 at 8:35
  • 1
    yaa switching to lightdm fixed the black screen issue. Thanks. – Abhimanyu Aryan Dec 12 '15 at 23:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.