6

I want to install Bugzilla on Ubuntu 14 version . in order to do so I have to install the following packages

apt-get install libappconfig-perl libdate-calc-perl libtemplate-perl libmime-perl build-essential libdatetime-timezone-perl libdatetime-perl libemail-sender-perl libemail-mime-perl libemail-mime-modifier-perl libdbi-perl libdbd-mysql-perl libcgi-pm-perl libmath-random-isaac-perl libmath-random-isaac-xs-perl apache2-mpm-prefork libapache2-mod-perl2 libapache2-mod-perl2-dev libchart-perl libxml-perl libxml-twig-perl perlmagick libgd-graph-perl libtemplate-plugin-gd-perl libsoap-lite-perl libhtml-scrubber-perl libjson-rpc-perl libdaemon-generic-perl libtheschwartz-perl libtest-taint-perl libauthen-radius-perl libfile-slurp-perl libencode-detect-perl libmodule-build-perl libnet-ldap-perl libauthen-sasl-perl libtemplate-perl-doc libfile-mimeinfo-perl libhtml-formattext-withlinks-perl libgd2-xpm-dev lynx-cur python-sphinx

However I am getting the following errors while executeing this command

Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'libmime-tools-perl' instead of 'libmime-perl'
Note, selecting 'libemail-mime-perl' instead of 'libemail-mime-modifier-perl'
Note, selecting 'perl-modules' instead of 'libcgi-pm-perl'
Package libnet-ldap-perl is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package libtemplate-perl-doc is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package libtemplate-plugin-gd-perl is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package apache2-mpm-prefork is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package libjson-rpc-perl is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package libsoap-lite-perl is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Unable to locate package build-essential
E: Unable to locate package libmath-random-isaac-perl
E: Unable to locate package libmath-random-isaac-xs-perl
E: Package 'apache2-mpm-prefork' has no installation candidate
E: Unable to locate package libapache2-mod-perl2
E: Unable to locate package libapache2-mod-perl2-dev
E: Unable to locate package libchart-perl
E: Unable to locate package libxml-perl
E: Unable to locate package perlmagick
E: Unable to locate package libgd-graph-perl
E: Package 'libtemplate-plugin-gd-perl' has no installation candidate
E: Package 'libsoap-lite-perl' has no installation candidate
E: Package 'libjson-rpc-perl' has no installation candidate
E: Unable to locate package libdaemon-generic-perl
E: Unable to locate package libtheschwartz-perl
E: Unable to locate package libtest-taint-perl
E: Unable to locate package libauthen-radius-perl
E: Unable to locate package libencode-detect-perl
E: Package 'libnet-ldap-perl' has no installation candidate
E: Unable to locate package libauthen-sasl-perl
E: Package 'libtemplate-perl-doc' has no installation candidate
E: Unable to locate package libfile-mimeinfo-perl
E: Unable to locate package libhtml-formattext-withlinks-perl
E: Unable to locate package libgd2-xpm-dev
E: Unable to locate package lynx-cur
E: Unable to locate package python-sphinx

What can be the issue I have also checked the apt.conf and it seems to be ok .

1

This basically means that the package doesn't exist anymore in the repositories or that one or more of your repository definitions in the /etc/apt/sources.list file or in the folder /etc/apt/sources.list.d/ are incorrect.

You can find more troubleshooting information in this very good thread: "Unable to locate package" while trying to install packages with APT

0

I think that the Bugzilla installation instructions were simply out-of-date when you were proceeding with the installation.

At this moment I am installing on Ubuntu 15.10 and following the instructions I have just an error related to apache2-mpm-prefork, but it seems fine just to remove it from the list of the required packages.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.