0

I re-installed Ubuntu as the only OS on my PC, deleting both Windows 7 and my previous Ubuntu 14.04 installation. But now, when starting my computer I see this message:

message when starting the computer

What does it mean?

Did I do something wrong?

I performed a pretty much standard clean installation, deleting everything.

A few things that come to my mind about doing anything different from my previous Ubuntu installation is that I checked the "Encrypt my Home folder" option and I ejected the installation CD when I got the message "Installation complete, please restart the computer" because of my BIOS setting being to start from the CD-Rom boot.

How can I 'fix' this (if there's anything to fix at all)?

I should say that Ubuntu feels a little more slow than it used to be on my previous installation, could this have anything to do with it?

I already did a full software update, still the same message.

PS: Sorry for the low quality of the picture, my camera is a potato, hope you get to see what is says.

A user pointed out to me the fact that this question is a duplicate of What to do about "the disk drive for /dev/mapper/cryptswap1 is not ready yet or not present"?, and there's a link to a possible answer on it but I really don't understand what that answer is saying, can someone PLEASE guide me through it?

I'm currently on step 4

Install gparted. Run it and format your swap partition as linux-swap. Make sure to get the right partition; if you get the wrong one, you'll lose possibly important data! The line you commented out in crypttab should give the correct partition name (it comes right after /dev/

But I don't really understand what it is I should do, here's an image to my gparted partitions:

gparted

I managed to do the steps 4 and 5. but now I'm on step 6

In the file /etc/initramfs-tools/conf.d/resume, find the line that says RESUME=UUID= followed by letters and numbers like (but not identical to) ..... from the last step. Replace them with ..... (i.e., with the letters and numbers mkswap gave after UUID=.) What does it mean by "In the file...". Where is that file, how do I open it?

I lost the "UUID" string and couldn't find it anymore so I just re-installed Ubuntu, left the "Encrypt my Home folder" option unchecked and the message just went away, I did understand eventually what the solution was because of the help obtained from Rohith Madhavan but because I couldn't find the "UUID" string again I got frustrated; I'm going to mark the question as solved though because of being another question's duplicate witch has been already solved.

By the way, I didn't removed the CD after the "Installation complete" message and, of course, there was a message telling me to do so when starting.

  • 3
  • I think it is, exactly, but I understand pretty much nothing about the solution, could you guide me? where it says "2. Open /etc/crypttab (e.g., sudo nano -w /etc/crypttab or sudo -H gedit /etc/cryptab for a GUI editor) and put a # at the beginning of the line that starts with cryptswap1. Save the file." How do I save the file? – favourites Jan 7 '15 at 18:37
  • 1
    nano is a command line text editor. To save a file after modification in nano, you need to press Ctrl+X followed by Y and Enter keys. – Rohith Madhavan Jan 7 '15 at 18:39
  • Great! I was able to save both files after commenting them, now, how do I do step 4? I already installed gparted but don't know what to do with it. Here's an image of my gparted thing. – favourites Jan 7 '15 at 18:44
  • 1
    To edit the file - sudo nano /etc/initramfs-tools/conf.d/resume – Rohith Madhavan Jan 7 '15 at 19:15
1

The error message indicates that the system was not able to mount the encrypted swap partition.

EDIT -

This question is a possible duplicate of What to do about "the disk drive for /dev/mapper/cryptswap1 is not ready yet or not present"?

Kindly refer to the particular question for the solution.

  • What does that mean, is that a problem? – favourites Jan 7 '15 at 18:24
  • Was your previous Ubuntu installation encrypted? – xangua Jan 7 '15 at 18:27
  • No, it was not. – favourites Jan 7 '15 at 18:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.