7

I don't know why, but somehow "ImageMagick" gained the status of being my default PDF viewing application (I didn't set it manually, maybe it came with the installation of iscan or plex).

Now, when I try to set Envince - or any other viewer - via [right-click on a PDF] > [Properties] > [Open with...] it happens nothing! ImageMagick remains as associated application.

Is there any way to get rid of that association? I guess ImageMagick is somehow made the systemwide standard on root level.

2
  • @fifaltra thank you, i know. but askubuntu wont allow me to do this before i have waited 2 days...
    – mgbler
    Jan 8 '15 at 9:01
  • ah, ok, sorry. I just comment that to all new users I see, because surprisingly many of them don't seem to know. :)
    – fifaltra
    Jan 8 '15 at 15:31
13

You don't need to delete the file and lose all the associations. You could just remove the lines that associate PDF to imagemagick. I just removed the following lines from ~/.config/mimeapps.list, and it worked!

image/pdf=display-im6.desktop
image/pdf=display-im6.q16.desktop;display-im6.desktop;
2
  • 1
    Or you can set your preferred application instead of removing the lines. evince.desktop in @mgbler's case.
    – berbt
    Apr 29 '16 at 10:48
  • If you don't know what the name of application is, you can try to find it in /usr/share/applications
    – user639188
    Jun 6 '18 at 10:46
2

Ok, I solved the problem:

Rename or delete

~/.config/mimeapps.list

That's it :-)

If you've set other than default apps for certain filetypes open System Settings > Information > Default Associations and (re)set your favourites there...

1
  • Removing the whole file is a bad idea. @viky's answer is better.
    – berbt
    Apr 29 '16 at 10:46
0

You don't have to remove anything, you can just change the line in ~/.config/mimeapps.list. It is probably:

image/pdf=display-im6.desktop

And you want it to be:

image/pdf=evince.desktop

Where evince.desktop is the name of PDF application launcher placed in /usr/share/applications that you want to have as default PDF viewer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.