3

I can't boot into the graphical interface. If I try to startx in the text mode. It outputs the following messages:

X.Org X Server 1.10.2.902 (1.10.3 RC 2)
Release Date: 2011-07-01
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-29-server i686 Ubuntu
Current Operating System: Linux host 3.0.0-8-generic-pae #11-Ubuntu SMP Fri Aug 12 22:20:08 UTC 2011 i686
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.0.0-8-generic-pae root=UUID=f7e8be67-a239-439b-90b4-ba4c634da473 ro quiet splash vt.handoff=7
Build Date: 13 July 2011  12:18:21AM
xorg-server 2:1.10.2.902-1ubuntu3 (For technical support please see http://www.ubuntu.com/support) 
Current version of pixman: 0.22.2
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Aug 15 01:11:23 2011
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE) Failed to load module "fglrx" (module does not exist, 0)
(II) [KMS] Kernel modesetting enabled.

But I have successfully installed fglrx by "apt-get install fglrx". If I manually insmod fglrx.so, I can see:

$ lsmod | grep fglrx
fglrx                2553695  0

But the startx still output the same message.

Any help or suggestion is really appreciated.

1

You appear to be using the 3.0 kernel - the default catalyst drivers that come with natty may not work with this kernel.

Can I suggest switching back to the standard natty kernel.

Alternatively, you should download and install Catalyst 11.7 or Catalyst 11.6 from the ATI website.

| improve this answer | |
  • I am using the Oneiric Ocelot. Just after an upgrade(not distro upgrade), the problem occurs. – user23287 Aug 14 '11 at 17:57
  • Sorry, I am not familiar with here... I will try to install AMD Catalyst 11.7! Thank you very much! – user23287 Aug 14 '11 at 18:05
  • ... ok - dont forget to uninstall fglrx first before installing catalyst 11.7. – fossfreedom Aug 14 '11 at 18:06
  • Yes, I won't forget it, :-) – user23287 Aug 14 '11 at 18:09
1

You have to run sudo aticonfig --initial once after the installation. If you haven't run this command yet it might be the cause of your problems

| improve this answer | |
  • But I don't have this command on my machine. When I apt-get install fglrx, it only installed fglrx and fglrx-amdcccle. – user23287 Aug 14 '11 at 17:52
  • did you try running it? – danjjl Aug 14 '11 at 17:52
  • Where can I find this command? – user23287 Aug 14 '11 at 17:53
  • When I try apt-cache search aticonfig, it shows nothing. – user23287 Aug 14 '11 at 17:53
  • I hadn't realized you where running Linux 3.0 kernel you should follow what fossfreedom is telling you – danjjl Aug 14 '11 at 17:54

Not the answer you're looking for? Browse other questions tagged or ask your own question.