For some reason I can't start mysql or cups using upstart i.e. "service cups start" results in "start: Job failed to start". How can I debug this? I also tried resintalling using synaptic, but that failed also, since it tries to start process also. This is with 11.04

  • Is there some detail in the logfiles? – user unknown Aug 14 '11 at 1:10
  • nope nothing I can see in the logs. – CptanPanic Aug 14 '11 at 1:43
  • Long shot I know but... MySQL gives this message when you remove /etc/mysql/my.cnf. – Rinzwind Aug 14 '11 at 5:31
  • Ok I found some more info: seems apparmor is having some problems. this is in boot.log AppArmor parser error for /etc/apparmor.d/usr.sbin.cupsd in /etc/apparmor.d/tunables/global at line 17: Could not open 'tunables/proc' – CptanPanic Aug 14 '11 at 13:14

I found the problem. The file /etc/apparmor.d/tunables/proc was missing, so I copied it from my backup and now it works.

  • Nice one! I was close with a missing my.cnf (but I knew that did not cover cups) :D Do upvote and accept your answer! – Rinzwind Aug 14 '11 at 13:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.