27

I need to connect to a L2TP IPsec VPN using Ubuntu 14.10. I previously used L2TP IPsec VPN Manager 1.0.9 from Werner Jaeger in Ubuntu 14.04, and it worked great, but that no longer appears to be supported in 14.10. I have xl2tpd installed. I no longer see the option to add a L2TP Ipsec VPN connection under the VPN Connections menu in Network Connections. Any help or guidance is appreciated.

20
+100

The lt2p-ipsec-vpn package was deprecated along with OpenSwan. Ubuntu has replaced OpenSwan with StrongSwan, which is available in the main, along with a corresponding network manager plugin in universe.

apt-get install strongswan network-manager-strongswan
  • 1
    l2tp-ipsec-vpn was deleted due to its dependency on openswan as well – Ben Grimm Jan 28 '15 at 22:19
  • 1
    @Pretzel did you ever succeed in getting IPSec/L2TP to work with pre-shared keys? – sbrattla May 1 '16 at 20:26
  • 9
    Could any of you show us how it's integrated with the network manager applet. I have installed these programs but don't see any additional options in nm. – Brandon Bertelsen May 28 '16 at 0:48
  • 7
    Not sure if I'm missing something, but this solution does not make L2TP available in VPN connections. – Seth Jun 2 '16 at 22:20
  • 1
    Yes, currently it doesn't show up on the network manager. This is already known bug: bugs.launchpad.net/ubuntu/+source/network-manager-strongswan/… Fortunately, someone has applied some patches to solve this and made them available through this PPA: launchpad.net/~raharper/+archive/ubuntu/bugfixes – Akronix Feb 27 '17 at 11:12
0

StrongSwan should work with xl2tpd

I know it's a best practice to paste the actual scripts but it's quite a bit. And honestly a link here would have saved me some trouble so hopefully someone finds this useful...

http://www.jasonernst.com/2016/06/21/l2tp-ipsec-vpn-on-ubuntu-16-04/ https://www.rapidvpn.com/setup-vpn-l2tp-ubuntu https://gist.github.com/psanford/42c550a1a6ad3cb70b13e4aaa94ddb1c

Maybe after I'm done I'll share the final script.

EDIT

A few implementation notes

  1. I had to remove the lock keyword from /etc/ppp/options.l2tpd.client
  2. Username and password should be specified when echo into /var/run/xl2tpd/l2tp-control
  3. rightsubnet=0.0.0.0/0 was added to the connection in /etc/ipsec.conf even though mine was a site-to-site VPN
  4. ip link lists your devices. There should be a pppN in the list where N is a number from 0
  5. For site-to-site I used the following to add a new route... ip route add 192.168.192.0/24 dev ppp0

protected by Community Jun 13 '16 at 10:06

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.