2

Before we begin, please excuse my complete ignorance, I am a relative novice to system administration.

I know there are a few posts so far about Ubuntu 14.04 messing with VNC connections. So far my case does not seem to match theirs and I have tried many fixes.

I was running Ubuntu 12 LTS with Webmin, SSH, Samba, and VNC viewer for remote connections. I upgraded to 14.04 and now VNCviewer connections can be made but yield a grey screen with what appear to be little fabric looking threads criss-crossing the screen.

I have tried all the dconf edits such as unchecking "enabled" and "encryption"

I have also changed the xstartup from the defaults to some alternative versions that load up the gnome desktop.

My question: Is this something that will just have to be resolved by the Ubuntu crew eventually and there is nothing I can do?

I am happy to post any information needed to answer your questions and retry solutions that you think will work.

I wanted to post a picture but I don't have enough reputation. Here's a link to the screenshot of a the VNC connection.VNC screenshot

4

Upgrading to Ubuntu 14.04 reset the permissions for .vnc/xstartup. The log file that are found in the .vnc folder for each session was crucial to understanding what was going on. To fix this I used

sudo chmod 755 xstartup

This solved that problem but I was then left with a grey screen. After parsing through tons of solutions, none of which helped me I found this:

how-to-install-and-configure-vnc-on-ubuntu-14-04

I used the contents of the xstartup file listed there to get a passable vnc desktop

#!/bin/bash
xrdb $HOME/.Xresources
startxfce4 &

All in all I'm really disappointed with this desktop setup but I'm hoping that some day the Unity environment will be available for VNC connections.

1
  • For myself, also had to terminate any existing vncserver sessions via -kill and then restart them of course ( after making these changes ) .. Then everything thankfully started working fine
    – sean2078
    May 18 '17 at 12:09
0

I have had the same problem.

I went through every walkthrough I could find and changed all those settings that worked for everybody else. (dconf, permissions on ~/.vnx/xstartup, all that)

It turned out that I had installed too many desktop environments, and VNC didn't like it.

I was testing i3, kubuntu, gnome, xfce, and a couple others. I found that once I'd installed all these desktops, I couldn't uninstall them, even with apt-get --purge remove desktop and apt-get autoremove.

I reinstalled Ubuntu and installed just kde, VNC has worked fine since then.

3
  • 1
    Thank you Zach. I don't think that I am using as many desktop environments as you. I went from gnome in 12.04 to gnome in 14.04. Could you tell me how to you check the number of desktop environments? I wanted to avoid a fresh install since the task of setting up samba, users, ssh, etc. was a Herculean task to begin with. I guess I can try to start a fresh set up on another system and see if I can get VNC working with a fresh install of Ubuntu 14.04.
    – Machindo
    Jan 7 '15 at 14:35
  • I couldn't find a command to say "show me all the installed desktops". The best I could do was: cd /etc/ ls. I could see xfce4, gnome and all it's tools, kde, i3, everything from there. If you have access to the desktop it's much simpler. Just navigate to the log in screen and in the top right corner there will be a couple icons, one of which you can click on and choose between all available desktops. I've also been unsuccessful at configuring starting VNC from the command line. Even after the fresh install, I had to log in to the server desktop locally and run vncserver.
    – Zach Olson
    Jan 8 '15 at 15:45
  • Could you share your xstartup?
    – Machindo
    Jan 30 '15 at 0:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.