1

I'm trying to access remotely to Ubuntu virtual OS from the host OS which in this case is linux Mint. My Ubuntu version has no GUI, just a terminal interface.

And change the network setting in virtual OS setting like this:

Network adapter is enabled.
Attached-to Host-only Adapter
vboxnet()

I run the virtual OS and login. Then via terminal in my host OS i do like this:

ssh -v -Y localhost@192.168.56.1
localhost@192.168.56.1's password:
Permission denied, please try again.
localhost@192.168.56.1's password:
Permission denied (public key, password)

What is wrong and how i can access it remotely?

Update: detailed log

myusername@linuxmint ~ $ ssh -v -Y localhost@192.168.56.1
OpenSSH_6.6.1, OpenSSL 1.0.1f 6 Jan 2014
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug1: Connecting to 192.168.56.1 [192.168.56.1] port 22.
debug1: Connection established.
debug1: identity file /home/myusername/.ssh/id_rsa type -1
debug1: identity file /home/myusername/.ssh/id_rsa-cert type -1
debug1: identity file /home/myusername/.ssh/id_dsa type -1
debug1: identity file /home/myusername/.ssh/id_dsa-cert type -1
debug1: identity file /home/myusername/.ssh/id_ecdsa type -1
debug1: identity file /home/myusername/.ssh/id_ecdsa-cert type -1
debug1: identity file /home/myusername/.ssh/id_ed25519 type -1
debug1: identity file /home/myusername/.ssh/id_ed25519-cert type -1
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_6.6.1p1 Ubuntu-2ubuntu2
debug1: Remote protocol version 2.0, remote software version OpenSSH_6.6.1p1 Ubuntu-2ubuntu2
debug1: match: OpenSSH_6.6.1p1 Ubuntu-2ubuntu2 pat OpenSSH_6.6.1* compat 0x04000000
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5-etm@openssh.com none
debug1: kex: client->server aes128-ctr hmac-md5-etm@openssh.com none
debug1: sending SSH2_MSG_KEX_ECDH_INIT
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug1: Server host key: ECDSA 63:3c:9e:9c:c7:fd:dd:8c:51:ed:1b:e1:54:bf:39:93
debug1: Host '192.168.56.1' is known and matches the ECDSA host key.
debug1: Found key in /home/myusername/.ssh/known_hosts:1
debug1: ssh_ecdsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: Roaming not allowed by server
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey
debug1: Next authentication method: publickey
debug1: Trying private key: /home/myusername/.ssh/id_rsa
debug1: Trying private key: /home/myusername/.ssh/id_dsa
debug1: Trying private key: /home/myusername/.ssh/id_ecdsa
debug1: Trying private key: /home/myusername/.ssh/id_ed25519
debug1: No more authentication methods to try.
Permission denied (publickey).

It still doesn't work. It seems the problem in the public key. What is that? Sorry, i'm still new about this.

0

Password auth is disabled on the SSH server by default. You first have to enable it. See: https://help.ubuntu.com/community/SSH/OpenSSH/Configuring

If the problem continue to exist, examine the sshd log file first.

Also note that you have to provide your login name, not the server name: ssh -v -Y username@192.168.56.1

| improve this answer | |
  • It still said permission denied (public key). Seems like no difference with the first one. It just keep asking key – Mas Bagol Jan 6 '15 at 10:44
  • sshd log output? – Andreas Jan 6 '15 at 10:47
  • Sorry, where is that? – Mas Bagol Jan 6 '15 at 10:48
  • Just read the troubleshooting guide in the link I posted above. Also look at the sshd log in /var/log – Andreas Jan 6 '15 at 10:53
  • - is your username really "localhost"? - did you restart the sshd after updating the config file? – Andreas Jan 6 '15 at 11:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.