1

I was using UBUNTU 12.04, and I tried updating it. Since then whenever I startup I get an error - "Plymouth: could not start splash: can not access a needed shared library."

After showing this error when I see the login screen, and enter my password. The screen just blinks and reshow the startup screen.

My update was for version 14.04. Is there any solution to this without loosing the data inside?

if anyone knows the answer kindly share.

Saurabh

  • Did you find any solution? – Dr.jacky Dec 7 '15 at 7:08
0

Using the sudo command, especially from a Live CD can do serious damage to your system. When pasting into the Terminal, use Ctrl+Shift+V, NOT Ctrl+V.

Mount the partition your Ubuntu Installation is on. If you are not sure which it is, launch GParted (included in the Live CD) and find out. It is usually a EXT4 Partition. Replace the XY with the drive letter, and partition number, for example: sudo mount /dev/sda1 /mnt.

sudo mount /dev/sdXY /mnt

Now bind the directories that grub needs access to to detect other operating systems, like so.

sudo mount --bind /dev /mnt/dev 
sudo mount --bind /dev/pts /mnt/dev/pts 
sudo mount --bind /proc /mnt/proc 
sudo mount --bind /sys /mnt/sys

Now we jump into that using chroot.

sudo chroot /mnt

Now install, check, and update grub.

This time you only need to add the drive letter (usually a) to replace X, for example: grub-install /dev/sda, grub-install –recheck /dev/sda.

grub-install /dev/sdX

grub-install --recheck /dev/sdX

update-grub

Now grub is back, all that is left is to exit the chrooted system and unmount everything.

exit &&
sudo umount /mnt/sys 
sudo umount /mnt/proc
sudo umount /mnt/dev/pts
sudo umount /mnt/dev
sudo umount /mnt

Shut down and turn your computer back on, and you will be met with the default Grub2 screen.

If the above not yet fixed try to add the below parameter to grub.

Start your system and wait for the GRUB menu to show, if you don't see a GRUB menu, press and hold the left Shift key right after starting the system

Now highlight the kernel you want to use, and press the e key. You should be able to see and edit the commands associated with the highlighted kernel.

Go down to the line starting with linux and add your parameter foo=bar to its end. Now press Ctrl + x to boot.

To make this change permanent:

From a terminal (or after pressing Alt + F2) run:

sudo vim /etc/default/grub

and enter your password.

Add the below line

set gfxpayload=keep

Save the file and close the editor.

Then run

sudo update-grub

to update GRUB's configuration file (you probably need to enter your password).

On the next reboot the kernel should be started with the boot parameter.

  • this is not working , it says mnt/dev not found. – saurabh Jan 14 '15 at 8:54
  • That means you not doing it properly. You have not said what the steps done by you. – Babin Lonston Jan 14 '15 at 8:56
  • Does it work for Ubuntu "Server" 12.04.5 too? – Dr.jacky Dec 7 '15 at 7:08
  • Yes it will work – Babin Lonston Dec 7 '15 at 16:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.