0

This question already has an answer here:

I was having trouble with my ubuntu dual boot so I ran the boot repair usb and was able to boot normally once. I tried to boot again and a screen with minimal grub bash 1.99 came up. I tried the boot repair again and the same screen came up. Here is info from the boot repair. http://paste.ubuntu.com/9679354/

marked as duplicate by Eric Carvalho, Fabby, David Foerster, v2r, Volker Siegel Mar 17 '15 at 8:35

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1

This looks like a Wubi install, and likely you had NTFS filesystem corruption, perhaps due to a hard shutdown? or some other crash. In any event, running boot-repair on Wubi installs is not a good idea... because it's not written by someone familiar with how Wubi works.

What you should do on a Wubi install is first run chkdsk from Windows, because the host filesystem is often what is corrupted, and only then, if necessary, fsck the root.disk.

But boot-repair will always offer to fsck the root.disk and this can result in a catastrophic loss. Right now it's reported a zero file size.

So, you should run chkdsk /r on the host drive and see if you have an intact \ubuntu\disks\root.disk. Otherwise it's probably damaged beyond repair.

Not the answer you're looking for? Browse other questions tagged or ask your own question.