0

I recently bought a XPS 15 with Windows 8.1 on it and I'd like to install Ubuntu 14.10 along the side. I've copied the .iso file on a USB stick and registered it as a boot option in the BIOS/UEFI. I've disabled in BIOS the Secure Boot option as well as the Intel Fast Response Technology.

The issue that I have is that when I choose to run the UEFI ubuntu installation boot option, after about a minute, the startup of windows bootloader kicks in. I have to mention, that in the case that i use the secure boot option as enabled, a warning window saying that the signature is invalid is displayed after which the installation is aborted.

I've also USB Universal Installer with the Ubuntu .iso file, and when using the Legacy boot mode, I get to the installation screen of Ubuntu. I'll probably try to install it this way and afterwards convert it to EFI as described here : https://help.ubuntu.com/community/UEFI#Setup_the_BIOS_in_EFI_or_Legacy_mode

I've followed the instructions presented on several other resources on this topic :

but I haven't seen any resources on how to deal with the issue that I'm dealing with.

I've tried before going on with the changes to start the boot-repair-disk as a Boot option and i get the same result as for the Ubuntu installation iso, after aprox. 1 minute Windows bootloader kicks in.

  • Do you have drive in AHCI mode. That may be separate from Intel setting. Ubuntu is using the Windows signing key, so it should boot with secure boot on, but usually better to have secure boot off, but UEFI mode on. Link says to have Legacy on,but boot in UEFI mode, so not sure how you do that with your system. I might try different installers, some for whatever reason work better than others with some systems, unetbootin, pendrive, if Windows Rufus, perhaps others. – oldfred Jan 5 '15 at 16:34
0

After several failed attempts I've made it to install Ubuntu on Dell XPS 15. I have disabled the secure boot option and have enabled the legacy boot option. Afterwards when restarting, I've used a USB key formatted with FAT32 on which I had the AMD64 distribution of Ubuntu 14.10 prepared (from Windows 8.1) with the Universal USB installer tool.

In my case, there was not necessary anymore to add from BIOS another Boot option by selecting the .ISO file from the USB drive, but instead was enough to have Ubuntu installation kit on the USB drive (after being prepared with USB Universal Installer).

When restarting I've pressed F12 and then I saw the Ubuntu installation from the USB key as an UEFI Boot option. Installation went fine (make sure to use 'Something else' in the first step when choosing whether the installation should purge the content of the HDD/SDD), the only thing to keep in mind when doing the installation is to choose /dev/sda as Bootloader location and after the installation is complete restart again directly in Linux in order to be able to run boot-repair tool. In order to avoid any grub related issues (like I did), make sure to eject the USB when restarting the computer after the installation is complete.

0

Just disable secure boot in bios and then enable legacy ROMs. I've confirmed it's as simple as this with the XPS 15's. This goes for the XPS 13 as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.