3

I have a Samsung Series 9 laptop, model NP900X4C. For a long time now this laptop has had issues with the battery and AC adapter, like this, which got fixed about six months ago: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/971061

Ever since I upgraded to 14.10 I've had a lot of problems, but the most problematic is that I can no longer unplug or plug in the AC adapter while the system is running. If I do, it simply freezes. Mouse stops responding, keyboard stops responding, everything else appears to stop responding. Just completely freezes. Nothing in any of the logs in Log Viewer. Removing the adapter (if plugging it in was what froze the laptop) or vice versa does nothing. The only way to get it to respond is to hold the power button to turn it off.

If the laptop is suspended or hibernated, I can unplug or plug in the adapter and the laptop will work normally after resumed.

I've tried with both the bundled charger and a third party charger, to rule out problems with the charger. Same effect.

Does anyone know what could cause this?

6
  • To be more specific to detect the issue whether it affects all H/W OR just to your Display(it graphics card) or Kernel. When this issue happens have you ever noticed to HDD LED light that usually blinks as per the usage of HDD when your system is running, if it's also freezes then this might be your H/W issue.
    – Novice
    Commented Jan 8, 2015 at 15:35
  • @Novice I'm not convinced it's a hardware issue, as it never happened with 14.04. I also don't have a HDD light on the laptop. Commented Jan 9, 2015 at 0:29
  • OK. So lets start checking for the S/W fault, so have you gone through the Kernel's last boot logs(if not you can find it from: /var/log/messages (or /var/log/syslog on some systems)), does any of the log have any error message recorded regarding this.?? So we can come to know the exact error regarding this issue.
    – Novice
    Commented Jan 9, 2015 at 5:43
  • @Novice like I said, nothing in any of the logs in the log viewer. Commented Jan 9, 2015 at 5:44

3 Answers 3

1

I had the same problem. Upgrading to 15.04 fixed it for me.

4
  • Do you have the same hardware? If that's true, it would be worthwhile to try a kernel upgrade first, before upgrading the entire system. Commented Apr 4, 2015 at 21:17
  • It would be nice if you could improve your answer by adding some detail or explanations. Maybe you can find out what the difference between 14.10 and 15.04 is (concerning this issue). Thanks for your effort.
    – Byte Commander
    Commented Apr 4, 2015 at 21:30
  • I'm glad to hear it Kenneth! I hope I can mark this resolved in a few weeks when 15.04 final is out! Commented Apr 5, 2015 at 2:59
  • Just upgraded to 15.04 and the problem is resolved! Hooray! Commented Apr 24, 2015 at 2:01
1

I've had the exact same problem about 2 years ago.

Some background: I was always very careful about using the battery as little as possible:

  • Always completely discharge the battery before charging again.
  • Take it out of the machine whenever I was home and plugged in anyway
  • Store it in a cool, dry place
  • Stop charging when the charge reads 100%
  • for more info : http://batteryuniversity.com

And I had the exact same problem as you after 6 years of that, so I knew the battery had finally died though it still worked (kinda: with the freezes, but what the heck: 6 years!)

If you have a relative, friend, colleague, ... that has the same laptop as you, just swap the batteries and you'll know as well your battery is busted.

0

I don't have a full solution, but at least you should (hopefully) not have to switch the computer off and on again, which is time consuming.

  • First press Ctrl+Alt+F6 (or anything except F7)
  • When it goes to a black screen with a blinking curser then press Ctrl+Alt+F7

Does that unfreeze your screen? If so then it's a problem with the X Windows driver.

2
  • Unfortunately, I've tried that, and the computer doesn't respond to trying to switch ttys when frozen. Commented Jan 14, 2015 at 3:06
  • Doh, sorry to hear that. An unfortunate situation to be in. Before I found this solution I was always having to turn my computer off - such a pain! I hope a solution comes up soon - that's a weird one. Commented Jan 14, 2015 at 4:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .