0

I am mounting a Windows 7 Home Premium 64-bit system partition on my Ubuntu 14.04.1 LTS 64-bit installation in order to be able to share data between the two OSs. The problem is that although I explicitly give the option permissions in /etc/fstab file I cannot chmod the files or directories inside the mounted drive. I also experimented with it and noticed if I only supplied permissions option while mounting(after unmounting everything) it and changed into the mount directory I noticed that everything had chmod 777 permissions, but I was able to alter the permission via the chmod command. The command is as follows in the command prompt:

mount -t ntfs-3g -o permissions /dev/sda5 /mnt/DATA/

However, I noticed even when I supplied my uid and gid to own the files the option permissions stopped having an effect. I tried appending and prepending it into the list of options just to make sure, and it turned out that in both cases I was not able to alter the permissions with chmod. The codes I used in command prompt is as follows:

sudo mount -t ntfs-3g -o uid=1000,gid=1000,permissions /dev/sda5 /mnt/DATA/

After unmounting, one more try as follows:

sudo mount -t ntfs-3g -o permissions,uid=1000,gid=1000 /dev/sda5 /mnt/DATA/

Both of these configurations did not allow me to change the settings and the option permissions had literally no effect. In my /etc/fstab file I define the line for mounting the NTFS partition as follows:

# data was on /dev/sda5 always
UUID=01CCA0086DD8A980   /mnt/DATA                 ntfs  auto,users,uid=1000,gid=1000,dmask=022,fmask=133,permissions       0       0

How can I make permissions options work so that I can change the permissions on the go without having to remount the partition totally? I read somewhere in this website it as possible, but I am unsure of how to do it. I would greatly appreciate any comments suggestions on this issue. My full /etc/fstab is as follows:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda6 during installation
UUID=c6cc14c0-aa75-4660-9e45-10a8fadedb64 /               ext4    errors=remount-ro 0       1
# /home was on /dev/sda8 during installation
UUID=30c60dd5-3c79-4e36-8ed7-d8035422f0b6 /home           ext4    defaults        0       2
# swap was on /dev/sda7 during installation
UUID=ffbc51d4-25b3-413f-aed1-14eba0f769c7 none            swap    sw              0       0
# data was on /dev/sda5 always
UUID=01CCA0086DD8A980   /mnt/DATA                 ntfs  auto,users,uid=1000,gid=1000,dmask=022,fmask=133,permissions       0       0
  • permissions and uses user-mapping, which conflicts with uid and gid. Pick one and stick with it. – muru Jan 5 '15 at 1:34
  • @muru Sorry I did not understand what did you mean exactly, could you elaborate a bit on that? Did you mean that I cannot use permissions with uid and gid? But using it with user-mapping` is possible. Did I get it right? – Vesnog Jan 5 '15 at 13:38
2

The best method I was able to find is the fstab entry below for the desired NTFS drive:

UUID=473577933B1627FB /media/username/Data\040Drive ntfs nosuid,nodev,nofail,x-gvfs-show 0 0

You will have full permissions to the mounted drive. This was done on ubuntu 14.10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.