10

I am running Ubuntu 14.04 LTS on a Dell 3542 laptop. My problem is that screen brightness changes depending on content. I think this is called automatic (or dynamic) brightness adjustment, as I stated in the title. This means that the screen gets brighter when the contents are white (for example when I open my browser) and it gets dimmer when the contents are dark (for example when I open the terminal). This can easily be seen when I open a white window and a black window and I proceed to move the black window in and out of the screen, so the brightness constantly changes.

I have done a fair amount of research, and the issue seems to have something to do with the power saving feature of the graphics card. This issue seems to be resolved in windows environments, but I have not found a solution for Ubuntu.

You should also know that this issue appears only when I run the laptop on battery, and disappears as soon as I plug it in. This probably means it has something to do with power saving.

The graphics card is a Nvidia GeForce 840M, and its control center in Linux does not have an option to disable power save (or to tackle the issue) whatsoever.

All in all, the constant brightness adjustment is quite annoying, to the point that I have to plug my machine in in order to use it for extended periods of time.

Any help would be greatly appreciated.

  • NVidia driver support is quite flaky at the moment. If no one comes up with a decent solution (have you tried disabling power management in your BIOS)? I would: drain the battery, store it in a cupboard and come back in a few months when support has improved. – Fabby Jan 4 '15 at 15:33
  • I entered my BIOS, and I did not see any power management settings... Are there any other options? – alex Jan 4 '15 at 17:12
  • Have a look at your BIOS for APM before trying this: askubuntu.com/questions/67355/… – Fabby Jan 5 '15 at 9:36
  • Did you find any solution? – 0xc0de Jul 25 '15 at 12:27
  • Have you tried this: askubuntu.com/questions/312603/… – ASO Oct 4 '16 at 12:45
2

According to https://ubuntuforums.org/showthread.php?t=2021064 :

  1. Click on system settings,

  2. Click on 'brightness and lock' in the menu,

  3. Uncheck the option ' dim screen to save power'.

If that doesn't work:

Open up your terminal and run:

sudo nano /etc/modprobe.d/blacklist

Then at the very end of the file add:

blacklist video
1

From Ubuntu Website laptops with integrated light sensors can be controlled through the Settings -> Power -> Automatic Brightness option.

Additionally you usually can completely turn off the ambient light sensor in BIOS which I believe most people would do who are annoyed by the feature.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.