5

I have a new AOC e1649WU DisplayLink usb monitor, but when I plugged this into my Fujitsu laptop running on Ubuntu 14.04, it remains black and in Utility, after hitting detect displays, no additional display is detected. On windows, it works fine after installing DisplayLink's drivers. I am relatively new to Linux, would appreciate it if I just follow the answer posted in this question? link (I am not sure if it is applicable to Ubuntu 14) with the package downloaded from here.

I am just hoping to get an extended display setting up dual monitors.

Here is some information about my system:

enter code here

> uname -a

Linux schoen-mind 3.13.0-43-generic #72-Ubuntu SMP Mon Dec 8 19:35:06 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

> xrandr

Screen 0: minimum 8 x 8, current 1366 x 768, maximum 16384 x 16384
VGA-0 disconnected (normal left inverted right x axis y axis)
LVDS-0 connected primary 1366x768+0+0 (normal left inverted right x axis y axis) 322mm x 181mm
1366x768       60.0*+
HDMI-0 disconnected (normal left inverted right x axis y axis)
DVI-D-0 disconnected (normal left inverted right x axis y axis)

> dmesg
.......
[   71.631022] usb 1-1.2: Product: e1649Fwu
[   71.631027] usb 1-1.2: Manufacturer: DisplayLink
[   71.631031] usb 1-1.2: SerialNumber: DZRE8HA026443
[   71.633268] hid-generic 0003:17E9:4107.0004: hiddev0,hidraw3: USB HID v1.10 Device [DisplayLink e1649Fwu] on usb-0000:00:1a.0-1.2/input1
[   71.712080] [drm] vendor descriptor length:17 data:17 5f 01 00 15 05 00 01 03 00 04
[   71.810818] open /dev/fb0 user=0 fb_info=ffff8800acde1000 count=1
[   71.810949] Console: switching to colour frame buffer device 170x48
[   71.810958] udl 1-1.2:1.0: fb0: udldrmfb frame buffer device
[   71.810960] udl 1-1.2:1.0: registered panic notifier
[   71.810964] [drm] Initialized udl 0.0.1 20120220 on minor 1
[   71.811194] usbcore: registered new interface driver udl
[ 2035.345665] systemd-hostnamed[3060]: Warning: nss-myhostname is not installed. Changing the local hostname might make it unresolveable. Please install nss-myhostname!

> lspci -k | grep -A 2 -i "VGA"

01:00.0 VGA compatible controller: NVIDIA Corporation GF119M [GeForce GT 520M] (rev a1)
Subsystem: Fujitsu Limited. Device 1635
Kernel driver in use: nvidi     

Are there additional commands output I should post here? Recommendations is much appreciated!! Thank you.

3

On Aug 3, 2015, Displaylink finally released the USB Monitor driver for Ubuntu.

Link: http://www.displaylink.com/downloads/ubuntu.php

I have an AOC usb monitor and Ubuntu 14.04. After installing the driver, my usb Monitor start working.

If the driver works for your monitor, please let other people know by posting it. Many people waiting for this driver. I've been waiting for 2 years. :-)

  • 2
    Just an update (the requirements were probably changed since you answered), but as of 2/19/16 need to be running kernel version 3.16+ and Xorg 1.16+. If you're using 14.04, you're probably going to be out of luck as Xorg is 1.15. I tried updating my 14.04's Xorg and my desktop environment started going wonky. Not saying you can't get it working, but just something to be cautious about before just upgrading X to get this to work – Bender the Greatest Feb 19 '16 at 21:27
  • Any idea how exactly to run this? I tried sudo dpkg -i aoc_driver but I get an error. – Sridhar-Sarnobat Apr 27 '16 at 17:46
0

Unfortunatly DisplayLink hardware is still incompatible with most linux distros. https://bbs.archlinux.org/viewtopic.php?id=151463

  • I see. Have returned that to Amazon already. But thanks! – jjxxll Feb 21 '15 at 5:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.