0

I am using Dell Inspiron N5010 core i3 processor and 4gb RAM ! My laptop takes up a lot of time to start up! typing dmesg in terminal gave these results !

[50.214177] audit_printk_skb: 150 callbacks suppressed 
[50.214182] type=1400 audit(1420344022.204:62): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/lib/cups/backend/cups-pdf" pid=2081 comm="apparmor_parser" 
[50.214189] type=1400 audit(1420344022.204:63): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/sbin/cupsd" pid=2081 comm="apparmor_parser" 
[50.214714] type=1400 audit(1420344022.204:64): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/sbin/cupsd" pid=2081 comm="apparmor_parser" 
[307.808672] perf samples too long (2780 > 2500), lowering kernel.perf_event_max_sample_rate to 50000

So it seems like the problem is with

[307.808672] perf samples too long (2780 > 2500), lowering kernel.perf_event_max_sample_rate to 50000

kindly help :)

1
  • How long is too long? You're saying it takes 300 seconds from POST to working? – Xen2050 Jan 4 '15 at 6:47
0

Could try unplugging any accessories, especially USB devices, sometimes they can cause delays when starting up. And see if it boots any faster afterwards.

Or could be that your computer is too slow for Ubuntu Unity (main version), you could try a "lighter" version like Xubuntu, Lubuntu, maybe Kubuntu, or use a different Window Manager like one from a version mentioned, or Openbox, etc... [ Why does it take over a minute for the desktop to load after logging in? ]

You can usually search for any log error messages to see generally what they mean: https://bbs.archlinux.org/viewtopic.php?pid=1330542#p1330542

Here is the commit with some background information: https://lkml.org/lkml/2013/5/29/640 More background on NMI here: http://x86vmm.blogspot.nl/2005/10/linux-nmis-on-intel-64-bit-hardware.html

It seems that the meta-information NMI's provide sometimes takes up too much CPU time; and the kernel throttles itself with an informational message as posted in this thread. The throttle is to prevent the kernel from taking up too much CPU while obtaining the nmi sample. You could tweak perf_cpu_time_max_percent but it seems the default is just fine

4
  • How would you tweak perf_cpu_time_max_percent? I see it listed in /proc/sys/kernel/perf_cpu_time_max_percent but don't imagine one should edit that file. Does this involve tweaking the kernel directly? – cboettig May 29 '15 at 17:58
  • @cboettig You can just write the new value into the file, as root echo 25 > /proc/sys/kernel/perf_cpu_time_max_percent or an echo <...> | sudo tee <file> should work too. See kernel.org/doc/Documentation/sysctl/kernel.txt and it's warning "some of the files _can_ be used to screw up your system, it is advisable to read both documentation and source before actually making adjustments" – Xen2050 Jun 17 '15 at 22:03
  • Right, so there's no sysctl command for that? I just recall /proc isn't like most root directories, and not all files can just be edited. (though wouldn't it be great if I could just edit /proc/meminfo like that and add more memory hehe) – cboettig Jun 18 '15 at 3:53
  • 1
    It appears in my sysctl -a output, "kernel.perf_cpu_time_max_percent = 25". With a little effort I'll bet you can lower your memory... increasing maybe a zram-type, or another stick & maybe a screwdriver – Xen2050 Jun 19 '15 at 6:11
0

If we focus on the line you call out in your question, this is by design and is just an FYI from the nmi-watchdog that things are taking longer than anticipated. So what appears to be the problem isn't. It seems performance reporting can be turned off but this won't help the speed at which your system is starting up. Since your system specs indicate that your system came with a 5400 RPM HDD you could try upgrading it to a 7200 RPM HDD, or even an SSD or adding RAM. Any of these approaches should increase boot speed but are unlikely to eliminate the message.

Sources: Experience, https://www.kernel.org/doc/Documentation/sysctl/kernel.txt , https://serverfault.com/questions/714648/how-to-disable-perf-subsystem-in-linux-kernel

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.