0

I forgot my user password. After resetting it using passwd menuka from recovery mode, I tried the new password in the terminal to run commands with sudo, but it keeps failing when I try the new password.

when I run the id command I got this.

$ id
uid=1000(menuka) gid=1000(menuka) groups=1000(menuka),4(adm),24(cdrom),27(sudo),30(dip),46(plugdev),108(lpadmin),124(sambashare)

Another issue is if I lock the computer and try to unlock the computer, the new password doesn't work. It works when I start the machine only.

I assumed the old password was cached in the system. I tried deleting password for the user menuka and updating it. But no success.

Can anybody help me to fix this issue?

5
  • 1
    Are there any special (e.g. punctuation, accented) characters in your password? What are the keyboard layout and language settings for your desktop session? What is the exact error message from sudo? – steeldriver Jan 4 '15 at 0:08
  • I use Uppercase, lowercase, numbers and @ charactor in the password. Keyboard layout is English(UK). when I try password it says sorry, try again.no error messages.. – newday Jan 4 '15 at 0:13
  • You can always use a grub prompt or a live dvd to reset the password to set it to a numbers/chars only password. And what is the error you are getting? – Rinzwind Jan 4 '15 at 0:19
  • 2
    +1 to @Rinzwind's suggestion - the @ character may be the culprit if your session has somehow got set to US keyboard layout – steeldriver Jan 4 '15 at 0:26
  • yes, when swith the keyboard layout, password started to work. I had to change it to UK – newday Jan 4 '15 at 0:44
1

Changing the keyboard layout as mentioned on the above comments solved the problem.

3
  • 1
    If you see that a suggestion from commenter you should report them back that it worked. Because they spent time on your problem and deserve one or two upvote. Don't they? – Anwar Apr 12 '17 at 7:17
  • I had upvoted the comments that were helpful – newday Apr 24 '17 at 23:39
  • I mean upvoting the answer or asking to answer the question as those worked for you. – Anwar Apr 25 '17 at 5:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.