Like my title said: I lost almost indicators on unity / Ubuntu 14.04.

I have tried restart indicator-sessions, deactivate practically all my software-indicators (maybe conflict).. but I have only Language/mail/sound/hour/gear all other app-indicators runs but not appear in the indicators bar.

Any idea?

  • What does ps x | grep --ignore-case indicator show?
    – Fabby
    Jan 4, 2015 at 14:07
  • @Fabby I put the result of this command on pastbin here : pastebin.com/paiYqxr6
    – NeurOSick
    Jan 6, 2015 at 14:01
  • 1
    I finaly found bug tracker about this issus on launchpad here bugs.launchpad.net/unity/+bug/1310200 I try the update -proposed
    – NeurOSick
    Jan 6, 2015 at 14:26
  • You should post that as an answer. A bug is an answer! ;-) And then accept your own answer! >:-)
    – Fabby
    Jan 6, 2015 at 16:06

1 Answer 1


I solved the problem by running sudo apt-get install indicator-applet-complete. All my indicators are then reappeared I de-installed and everything remained. Why is working? I do not know, probably the installation of it has made it possible to correct a corrupted or missing file. (maybe) :)

  • You can accept your answer by pressing the green tick next to it :)
    – Wilf
    Jun 1, 2015 at 15:10
  • You may also be interested in reading this answer by hannesvr which explains how to bring the indicator icons back without either uninstalling or installing anything and without rebooting the computer.
    – karel
    Jun 1, 2015 at 15:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.