I'm using Ubuntu 14.04 LTS

I'm trying to update my drivers to the latest version provided by AMD. I couldn't find a way to simply update them, so I decided to uninstall them completely by doing this:

sudo apt-get remove --purge fglrx fglrx-amdcccle fglrx-dev
sudo apt-get remove --purge xserver-xorg-video-ati xserver-xorg-video-radeon
sudo apt-get install xserver-xorg-video-ati
sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core
sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.backup
sudo rm -rf /etc/ati

Then I rebooted, and ran:

./amd-driver-installer-14.501.1003-x86.x86_64.run

The installer generated the package and I installed it. I then tried to run

aticonfig --initial

but I get the error:

Unable to open /etc/ati/control, please reinstall the driver.
aticonfig: No supported adapters detected

Thinking the installation messed up, I uninstalled the drivers again, rebooted, and tried to install once more. I get the same error. How can I successfully install the drivers?

  • Why do you need ATI's proprietary driver? Was there something wrong with the open source one? – John Scott Jan 3 '15 at 18:21
  • 1
    @FuzzyToothpaste Yes, for example, OpenGL4 support. – mikewhatever Jan 3 '15 at 19:20
up vote 5 down vote accepted

Enable support for 32bit packages if you have a 64bit OS -

sudo dpkg --add-architecture i386

Install the following packages -

sudo apt-get install lib32gcc1 libc6-i386

Install all the dependencies listed on this page.

Download all the .deb files related to Ubuntu 14.04 (fglrx,fglrx-core,fglrx-dev and fglrx-amdcccle) from this page.

Copy the downloaded .deb files to a folder.

Now, open a Terminal and cd to the created folder -

cd /path/to/folder

Install the .deb files using dpkg -

sudo dpkg -i *.deb
  • 1
    If you try to install the deb files, you will encounter errors due to missing dependencies. You can either install these packages using the commands given or try to use the -f argument with apt-get install to force install the missing dependencies. – Rohith Madhavan Mar 1 '15 at 11:53
  • 1
    The downloads page (link provided) also explicitly mentions that 32bit packages must be installed for 64bit drivers to install or work. – Rohith Madhavan Mar 1 '15 at 11:58
  • Thanks for clarifying, I managed to install it all seamlessly using this method as well. I decided to install the dependencies myself following the erros outputed, but interestingly I didn't have to, the only package required by the installation was dkms, and all installed fine after installing it. – Ivan Lerner Mar 2 '15 at 2:17

I have Successfully installed AMD OMEGA Driver by following these steps :

Note: If you previously tried to install any openGL driver "fglrx" purge , autoremove . then reboot your system.

Now follow the steps which i have done to successfully install amd omega driver .

sudo apt-get update

finish the software updater pending list . go to Settings then goto Language and Support if updates there install it . Then click "Apply Syststem wide"

Then sudo apt-get install gksu

Get the amd omega driver for linux from official amd site get amd driver here

after getting amd-catalyst-omega-14.12-linux-run-installers.zip , unzip it

let me consider that file located in Downloads

cd Downloads/

unzip amd-catalyst-omega-14.12-linux-run-installers.zip 

cd fglrx-14.501.1003/

sudo chmod +x amd-driver-installer-14.501.1003-x86.x86_64.run 

./amd-driver-installer-14.501.1003-x86.x86_64.run 

The last action shows some dependency requirement error in /usr/share/ati/fglrx-install.log

NOTE

Even after error AMD Driver Proceed to Install don't do it cancel it .

read the error and then follow the steps given there

cat /usr/share/ati/fglrx-install.log

For me the dependency error showed me to in install the following components

sudo apt-get install debhelper

sudo apt-get install dh-modaliases

sudo apt-get install execstack

apt-get install dpkg-dev

sudo apt-get install dpkg-dev

sudo apt-get install dkms

sudo apt-get install lib32gcc1

After installing these Dependency Packages run

./amd-driver-installer-14.501.1003-x86.x86_64.run 

it will then follows next next installation , Be patient until it build packages and it install it automatically .

After installation Succesful

sudo reboot

To check whether the installation is Success or not run the following cmds in terminal

fglrxinfo

to Enable AMD Radeon DPM (Dynamic Power Management) Run the Following Cmds

gksu gedit /etc/default/grub

change GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.dpm=1"

sudo update-grub

Some Tweaks Regarding Brightness Getting Reset Fix (Optional) Read this Fix Brightness Getting Reset (To A Very Low Value Or Maximum) On Reboot In Ubuntu

For Power Management Consider installing this TLP and Laptop Mode

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.