1

Currently I am receiving warning messages about low disk space every few minutes. The warning message says The volume "home" has only 1.1 GB disk space remaining.

Receiving the warning periodically is fine, but the warning has now poped up 10 times during the last hour. Is there any way I can adjust the frequency of this warning, such that I only get the warning once every n hours or if the free disk space gets even lower?

With help from Mike's answer, I found some relevant settings in dconf-editor. One of them looks like it should do what I want. But it appears it isn't working.

I also found that the free space on the partition is going up and down over time. Apparently leaving any stackexchange pages open causes Chromium to continuously write to disk and periodically clean up. Each time this causes the disk usage to go above the threshold and below the threshold again, I get another warning regardless of the min-notify-period setting.

Is there a way to stop varying disk usage from causing excessive warnings without completely disabling the warnings? (As a temporary workaround I created a file with 200MB of zeros, just to keep the disk usage on the same side of the alert threshold for now.)

4

I don't know what OS you use, so this answer only applies to Ubuntu, and possibly Ubuntu Gnome.

Istall dconf-tools from the Sotware Center, then launch dconf-editor from a terminal window.
Navigate to /org/gnome/settings-daemon/plugins/housekeeping, and modify the settings there, or deactivate it. For example, to get the warning every two hours, set min-notify-period to 120. enter image description here

  • 1
    It is an Ubuntu 14.04 system using the default desktop environment. When I launch gconf-editor, I do not find the settings that you mention anywhere. The only choices are apps, desktop, schemas, and system. – kasperd Jan 3 '15 at 16:43
  • Is that gconf-editor or dconf-editor. The only thing in your screenshot that looks like gconf-editor is the window title. Everything else looks like dconf-editor`. – kasperd Jan 3 '15 at 16:53
  • I found the setting in dconf-editor and increased it from 10 to 120. It didn't help. It does however respect the active setting. If I disable that, the warnings completely stop. That is however not what I want. I just don't want to get notified as frequently. – kasperd Jan 3 '15 at 17:40
  • My mistake, thanks for the correction. I'll edit the answer above as well. If the min-notify-period doesn't work, try other settings as well. – mikewhatever Jan 3 '15 at 18:46
0

free-percent-notify-again

Adjust the value of min-notify-period as mikewhatever suggests, but maybe the option of free-percent-notify-again is causing the trouble as well. It says it accepts 0.0..1.0 with default of 0.01.

If I am interpreting this correctly setting 1.0 would double the percentage the free disk space should reduce by before issuing a subsequent warning. Which by the way, you can also set that value here too (free-percent-notify). It's just going to be a matter of either being able to do the math, or trial and error.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.