1

After using Boot Repair (recommended options) from an Ubuntu 14.10 Live System (USB) grub fails with the following error:

error: failure reading sector 0x7c3c00 from "hd0". 
Entering rescue mode...     

Boot Repair exits with errors and here is the paste-url: http://paste.ubuntu.com/9659889/ I assume to find the relevant error in the last lines:

cp: error reading ‘/mnt/boot-sav/sda7/boot/grub/grub.cfg’: Input/output error
cp: failed to extend ‘/var/log/boot-sav/log/2015-01-02__16h22boot-repair08/sda7/grub.cfg_old’: Input/output error
cp: error reading ‘/mnt/boot-sav/sda7/boot/grub/grub.cfg’: Input/output error
cp: failed to extend ‘/var/log/boot-sav/log/2015-01-02__16h22boot-repair08/sda7/grub.cfg_new’: Input/output error
cat: /mnt/boot-sav/sda7/boot/grub/grub.cfg: Input/output error

An error occurred during the repair.

Afterwards I tried to reinstall Ubuntu 14.10 newly from the live system. There are also different options like - delete and reinstall Ubuntu 14.10, etc. The installation didn't finish fully (after 10 hrs of no progress) so I broke it up @

Jan  3 15:51:00 ubuntu wpa_supplicant[3680]: wlan0: CTRL-EVENT-SCAN-STARTED 
 /usr/lib/ubiquity/ubiquity/frontend/gtk_components/nmwidgets.py:18: Warning: Source ID 30729 was not found when attempting to remove it
GLib.source_remove(self.timeout_id)

After rebooting the system the error is still the same.

There are different solutions for similar problems, but none of them worked out for me. (For example the solution of What to do when I get an "attempt to read or write outside of disk 'hd0'" error and Boot Repair does not solve the problem? results still in the same error after insmod normal)

System's hardware is a Lenovo Thinkpad T61.

Thanks in advance, I appreciate every kind of help!

UPDATE2: Here is the link to the last "BootInfo Summary" of Boot Repair http://paste.ubuntu.com/9670360/ where everything seems OK (for me at last).

I had a look at the live system and found a tool called "SMART Data and Self-Tests". Its possible to do some tests on the HDs. I've choosen the /dev/sda (the 160G disk where the primary error occurs), but it only says "SELF-TEST FAILED".

Currently I'm thinking about a solution where I save all the data on the disks and format the /dev/sda completely.

UPDATE3: I used the 'hard disk drive diagnostics program' from the BIOS and it finds an error at the very beginning of the test:

Status: Test in progress: 0%
Result: Pass: Controller Diag
Error code 0000: Read verification failed

I'm expecting it to be a hardware error. The sad thing is that there is no warranty left on the system since its about 6 years old.

Another thing I'm thinking about is to "locate" sector 0x7c3c00 from "hd0", but anyway I don't know how to do that.

  • "self test failed" means that hard drive didn't pass its normal test routine (obviously :D). If you have that issue, go for replacing HDD immediately - HDDs often die without detecting any sort of error, but if they detect it, that's the most certain indicator that your HDD is going to die soon. – gogeccc Jun 6 '16 at 12:17
0

I solved this by replacing the old HDD with a new one. I bought a SSD instead and installed Ubuntu 14.10 on it. It is very fast and every thing seems to work flawlessly instead of some minor issues.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.