4

This is really a major issue. Check what happened. Please Help me with a solution...

I had windows 7 installed in my laptop. I decided to install ubuntu 14.04 and remove windows 7. So while installing ubuntu 14.04 i selected remove windows 7 and install ubuntu (2nd option). I selected cryptdisk option while installing and set a password.

Later after installation i couldn't find my old partition and data. So I tried to check the partition and other settings. During this I shutdown my system and started again. (Remember never clicked restart instead used shutdown)

After a research i found testdisk software which can help for recovering partitions. I did it and found my partition and i selected to write the MBR to disk. After this testdisk asked me to restart to take effect. So I restarted the system (Notice this time i clicked restart icon). After this when the system restarted I entered the same cryptdisk password at ubuntu boot screen. but it didnt except and gave error: "requested offset is beyond real size of device ...." cryptsetup: cryptsetup failed, bad password or options?"

Please someone help me with this... Waiting for a good response. Thanks in advance.

1
0

What worked for me was reinstalling Ubuntu 14.04 and only using lowercase letters and a shorter password. There is most certainly a bug in this software.

2
  • Welcome to AskUbuntu! I removed a fair bit of your answer because it was not relevant to understanding the solution. I also removed an issue you were experiencing. Please Ask a question regarding any other issues. – wjandrea Nov 11 '16 at 6:37
  • No, there is most likely a different keyboard layout set at boot. – David Foerster Nov 11 '16 at 9:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.