0

I have tearing problem in Xubuntu 14.04 (both 64 and 32 bit)

first screen shot second screen shot third screen shot

I'm using an Aspire s3: http://www.itp.net/587066-acer-aspire-s3-ms2346?tab=specs

I have already installed the Intel driver but the tearing is present in every video player i use, how do i enable vertical sync?

1

To enable vsync you first need to enable xfce composite in the Window Manager Settings:

enter image description here

  • it's already enabled postimg.org/image/o5d31heqd – Luca Jan 2 '15 at 17:58
  • 1
    Now you only miss to check Synchronize rawing to the vertical line, vsync. @PhantomFav – xangua Jan 2 '15 at 19:29
  • thank you, that was the problem, maybe you can remark to check this option in the answer. – Luca Jan 2 '15 at 19:38
2

I added a ppa from https://launchpad.net/~oibaf/+archive/ubuntu/graphics-drivers and updated my system.

I then added below lines to file /etc/X11/xorg.conf.d/20-intel.conf

Section "Device"
Identifier "Intel Graphics"
Driver "intel"
Option "AccelMethod" "sna"
Option "TearFree" "true"
EndSection

and restarted the System.

Now my system(with Intel graphics) is completely tear free and can use 'compositing' from "windows manager tweaks".

0

I can advise you to try Compton if standard tear-free option did not help you. It is Xcompmgr fork.

http://duncanlock.net/blog/2013/06/07/how-to-switch-to-compton-for-beautiful-tear-free-compositing-in-xfce/

I am using it with Nvidia, should work with Intel too. Do you have problem only in video or also in DE? In first case try other video drivers output in video player settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.